Home assistant 404 error Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
pbutterworth
Posts: 1
Joined: Fri Sep 18, 2020 3:22 pm

Home assistant 404 error

Post by pbutterworth »

Hi,

I tried to install Home assistant, the install seems to have worked and HA is running, but if I go to the web UI I get a 404: not found error.

I'm running DietPi v6.32.2 on a RPi 2 Model B.

I looked at the forum, and there was an old thread about this issue from 2019, but I can't find a resolution.

I'm not a total novice user, but am by no mean an expert either!

Any ideas?

Thanks
Paul
User avatar
Joulinar
Posts: 2277
Joined: Sat Nov 16, 2019 12:49 am

Re: Home assistant 404 error

Post by Joulinar »

Hi,

many thanks for your message, what URL you are using to access HA?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
novitibo
Posts: 87
Joined: Mon Feb 29, 2016 5:11 pm

Re: Home assistant 404 error

Post by novitibo »

sudo apt-get install libjpeg-dev zlib1g-dev

Restart HA and after a few minutes it came up…
User avatar
Joulinar
Posts: 2277
Joined: Sat Nov 16, 2019 12:49 am

Re: Home assistant 404 error

Post by Joulinar »

@novitibo
thx for sharing your solution. For me it was enough to perform apt install libjpeg-dev because zlib1g-dev was already present/installed.

Looks like some new dependency that would need to be added to dietpi-software installation process.

EDIT1:
just verified the apt dependency that will be installed by dietpi-software together with HA from

Code: Select all

DEPS_LIST="gcc libc6-dev make zlib1g-dev libbz2-dev libreadline-dev libssl-dev libsqlite3-dev libffi-dev $custom_apt_deps"
zlib1g-dev is already there, I will open PR on Github to add libjpeg-dev as well.

EDIT2:
PR up https://github.com/MichaIng/DietPi/pull/3781/files
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 2323
Joined: Sat Nov 18, 2017 6:21 pm

Re: Home assistant 404 error

Post by MichaIng »

Post Reply