Reason for xu4 high activity with nothing running ?

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
echable
Posts: 30
Joined: Mon May 20, 2019 3:03 pm

Reason for xu4 high activity with nothing running ?

Post by echable »

I've finally successfully installed and configured a perfectly working Logitech Media Server / Squeezebox player

This morning I awoke to find my xu4 audibly spinning. On SSH login it reported a "high, not recommended" temperature, LMS processes at the top of htop, and one single CPU kernel (out of eight) running at near 100%, going up and down notably.

This specific behaviour, that while checking htop there is one CPU kernel running at or near 100%, while other kernels are at 0%, I've seen several times. Is this normal ? Is it indicative of a defective xu4?

There was no music library scan running or anything, and the connected NAS where music files are stored (connected to LMS library on xu4 via SMB connection) was in sleep mode.

There is nothing installed on the xu4 except LMS/Squeezeplayer (and the SMB/NFS fileserver and the default logging/SSH server, is there perhaps some logging in DietPi or LMS that is on by default that could cause this that I can completely disable ?) I've not touched nice values/processor profiles ("on demand"/"performance" etc., that stuff), or changed much if anything of default settings in DietPi.

Any explanation / troubleshooting for this ? It's obviously detrimental to have the xu4 running at high activity/temperature when there is no playback, scanning or anything running. Could have something to do with plugins perhaps ? Any way to more accurately diagnose this ? Log files ?

Thank you very much for any help.
User avatar
MichaIng
Site Admin
Posts: 2421
Joined: Sat Nov 18, 2017 6:21 pm

Re: Reason for xu4 high activity with nothing running ?

Post by MichaIng »

In general, if all cores are used by a process or only one, is a matter of the program coding. It is not unusual that processes use one core only.

However if nothing is done, of course 100% CPU usage should not be the case. Log files of LMS can be found in: /var/log/squeezeboxserver/
Or check the systemd units log: journalctl -u logitechmediaserver
Post Reply