System no longer boots

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Tresi
Posts: 5
Joined: Mon May 13, 2019 8:02 am

System no longer boots

Post by Tresi »

Hello,

since this morning my Raspberry Pi with current DietPi release doesn't start anymore :(

I took a picture of the error message that comes right after starting.

Image

The sd-card seems to be ok. It is readable and shows no errors at another computer. A few hours ago, everything was fine.
Also several restarts changed anything, always the same.
I just installed the current update a few days ago, but I can't say exactly which version it was because I can't check it out anymore. I am using a Raspberry Pi 2.

I would be very happy for help.

Thanks in advance! :)

Kind regards,
Tresi
User avatar
MichaIng
Site Admin
Posts: 2293
Joined: Sat Nov 18, 2017 6:21 pm

Re: System no longer boots

Post by MichaIng »

@Tresi
Many thanks for your report.

If you updated a few days ago it was DietPi v6.22. However there is nothing done that could cause a kernel panic before even the init system starts.
I bet it is due to SDcard corruption. Usually those do not show when only plugging on anther system and even browsing a bid through it.

Do you have another Linux system where you can plug it? Because on Windows you can only see (and check) the FAT32 boot partition.

On a remote Linux system after plugging the SDcard, run fsck on both partitions, e.g.:

Code: Select all

apt-get -y install dosfstools
dosfsck /dev/mmcblk0p1
e2fsck -f /dev/mmcblk0p2
Tresi
Posts: 5
Joined: Mon May 13, 2019 8:02 am

Re: System no longer boots

Post by Tresi »

Checking the file system is the first thing I did on another computer. Everything ok.

In my first panic I overlooked a few things and forgot to mention them. I noticed that the system was suddenly unavailable. I tried to connect via SSH. Already then I got several error messages and I should install something to make SSH work properly. Something with terminal and/or ncurses. There was a dialog box where you could choose whether to do this or ignore it. I did that, of course, because I thought it would help. But unfortunately it didn't. Several other error messages came then still, which I unfortunately do not know more exactly. But there were missing files that couldn't be loaded etc.

Now I tried to reinstall DietPi on a new map. But already at the start of the software installation there are many errors again and when I restart I get exactly the same error message as on the picture.

Coincidentally a friend has reported that something is wrong with him because he can't access his Raspberry Pi. He has exactly the same errors and exactly the same system configuration. The errors only occurred today in his case as well. So it has nothing to do with the SD card, the Raspberry or the power supply, but is clearly due to the DietPi.

What's going on? Can I give further helpful information? My friend's system will continue to run as long as you don't restart it and I can still execute commands there. I'm not the periphery in Linux, but I'm getting some stuff out of it already. Just let me know what you want me to do. ;-)

Thanks a lot in advance.

Kind regards,
Tresi
Last edited by Tresi on Tue May 14, 2019 4:49 am, edited 1 time in total.
maarten
Posts: 34
Joined: Mon Nov 19, 2018 4:35 pm

Re: System no longer boots

Post by maarten »

Tresi wrote: Mon May 13, 2019 8:13 am Hello,

since this morning my Raspberry Pi with current DietPi release doesn't start anymore :(

I took a picture of the error message that comes right after starting.

Image

The sd-card seems to be ok. It is readable and shows no errors at another computer. A few hours ago, everything was fine.
Also several restarts changed anything, always the same.
I just installed the current update a few days ago, but I can't say exactly which version it was because I can't check it out anymore. I am using a Raspberry Pi 2.

I would be very happy for help.

Thanks in advance! :)

Kind regards,
Tresi
Experienced exactly the same after updating to v6.23 which includes an update of php... Kernel got corrupted and system would not boot anymore.

I strongly advise that v6.23 is not pushed and put on hold... There's clearly a problem....
Tresi
Posts: 5
Joined: Mon May 13, 2019 8:02 am

Re: System no longer boots

Post by Tresi »

@maarten

Even if it is of course a very annoying thing, I am still happy to read this. I thought I was the only one with these problems and could not classify them.

So far I have never had problems with DietPi and have always been very satisfied. I will now set up a Raspbian Lite and configure it until there is a solution. Without my Raspberry nothing runs here anymore, not even Internet (DNS server).

I hope that there is a quick solution :)

Many greetings,
Tresi
maarten
Posts: 34
Joined: Mon Nov 19, 2018 4:35 pm

Re: System no longer boots

Post by maarten »

@Tresi

Thanks, I am really frustrated. Everything worked like a charm (I was very very happy with DietPi) until yesterday...

Micha and Fourdee are great and really try to help as much as they can but my system is bricked and up until now I have not managed to restore the backup I made before initial upgrade to v6.23.

Had also some problems with previous update. So when it works, DietPi works great, but upgrating is very problematic.

I have two SBCs: a nanopi NEO2 with pi-hole as DNS server and a Raspberry Pi Zero W as music streamer, both running DietPi (headless). Upgrade to v6.23 for nanopi went smooth and completely hassle-free but I cannot get my RPi up and running again.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: System no longer boots

Post by johnvick »

What went wrong with trying to restore the backup? Did you try from a freshly flashed image on a different SD card?

John
maarten
Posts: 34
Joined: Mon Nov 19, 2018 4:35 pm

Re: System no longer boots

Post by maarten »

johnvick wrote: Tue May 14, 2019 6:22 am What went wrong with trying to restore the backup? Did you try from a freshly flashed image on a different SD card?

John
After reboot, boot hangs:

random: crng init done

--> found the problem, since i restored to newly formatted SD card I had to change the PARTUUID in cmdline.txt
User avatar
MichaIng
Site Admin
Posts: 2293
Joined: Sat Nov 18, 2017 6:21 pm

Re: System no longer boots

Post by MichaIng »

@Tresi
Which RPi model does your friend have? And did you have PHP installed and tried to install it on a fresh image as well?

Because on ARMv6 (RPi1 + RPi Zero) we found the issue now which is an incompatible php-fpm package that somehow corrupted the whole init system. We read and learned that the related repo is in general not ARMv6 compatible and the way Raspbian allows/ships armv6l compatible armhf packages then still allows installation (Usually APT block install of packages which are not compatible with the own architecture).

We just released v6.24 as hotfix to re-allow updates on ARMv6. PHP7.3 is now installed via Raspbian Buster repo where architecture compatibility is guaranteed.

However this only affects ARMv6. I read several other sources now that prove compatibility with ARMv7 and higher, so your RPi2 should not have run into this issue...

When you have it up running, could you please verify uname -m and if you know which exact RPi2 model it is?
Post Reply