Update from 6.4 to 6.6: 6.4 to 6.5 failed, 6.5 to 6.6 OK..??

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Frk
Posts: 7
Joined: Mon Oct 24, 2016 1:50 am

Update from 6.4 to 6.6: 6.4 to 6.5 failed, 6.5 to 6.6 OK..??

Post by Frk »

Hi!

First of all, thanks for DietPi. I've been using it since version 110 if I recall correctly and it's awesome! Thanks for all your hard efforts.

Today I tried to update my DietPi from version 6.4 to 6.6. Usually I make a backup before doing so, but today I was in a hurry and of course Murphy's law struck me: The update from version 6.4 to 6.5 went wrong. It was unable to download some depencies/apt files from raspberrypi.org. DietPi said it would terminate the program, but instead it automatically continued with updating to 6.6. This seemed to have gone fine; everything is working as it should as far as I can see, but I am a little concerned that I might end up with a corrupt installation.

Is there any way to verify, or repair, the current installation? I am using an old Raspberry Pi Model B with 256MB RAM.

Many thanks!
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Update from 6.4 to 6.6: 6.4 to 6.5 failed, 6.5 to 6.6 OK

Post by Fourdee »

Hi,

There was an external bug with a Raspbian package, which broke sources.list.
https://github.com/Fourdee/DietPi/issue ... -377297103

We did patch for this, however, just to make sure we should rerun 6.4 > 6.6 patch again:

Code: Select all

echo -e "6\n4\n" > /DietPi/dietpi/.version
dietpi-update
Please check for any errors and screengrab/paste them here if they occur.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Frk
Posts: 7
Joined: Mon Oct 24, 2016 1:50 am

Re: Update from 6.4 to 6.6: 6.4 to 6.5 failed, 6.5 to 6.6 OK

Post by Frk »

Many thanks for your reply!

This time the update went well from 6.4 --> 6.5 --> 6.6 without any errors. Thank you very much!!
Post Reply