Pihole installation works only after 2 installs

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
ripa
Posts: 12
Joined: Sat Oct 21, 2017 11:09 am

Pihole installation works only after 2 installs

Post by ripa »

Hey,

you need to install Pihole, reboot, uninstall Pihole, reboot, install Pihole to get it to work.
Nanopi Neo 512
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: Pihole installation works only after 2 installs

Post by Fourdee »

ripa wrote:Hey,

you need to install Pihole, reboot, uninstall Pihole, reboot, install Pihole to get it to work.
Hi,

Thanks for the report.

We were unable to replicate this on RPi 3/x86_64.

Can you confirm which device you are using, and, if any other software is installed on the system?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: Pihole installation works only after 2 installs

Post by k-plan »

ripa wrote:
you need to install Pihole, reboot, uninstall Pihole, reboot, install Pihole to get it to work.
Yes correct, depending on device you used. This happen form time to time after putting a fresh image on sd card, since DietPi use the default PiHole install methode (install.sh) and not DietPi own PiHole repository any more.
Installation breaks in the middle, without a message and you are back on cmd line. If this happen, you will notice, there is no pihole web password notification at the end of installaton process.
But no big deal, second installation works.
Fourdee wrote:Can you confirm which device you are using,...
For me, NanoPi Neo, OrangePi One, Odroid C1 (sometimes).
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
baz123
Posts: 166
Joined: Thu Jan 12, 2017 9:23 pm

Re: Pihole installation works only after 2 installs

Post by baz123 »

Yes I see this as well. A fresh image, no webserver installed. OrangePi Zero

On first install, I didn't see a message asking if I want to install the web interface so it is breaking about there.

2nd install seems to be fine.
ripa
Posts: 12
Joined: Sat Oct 21, 2017 11:09 am

Re: Pihole installation works only after 2 installs

Post by ripa »

NanoPi Neo

If its not using your repo: Is there no difference between diet-pi autoinstall and "curl -sSL https://install.pi-hole.net | bash"? No optimizations needed/possible?
Nanopi Neo 512
Post Reply