USB audio issues on Asus Tinkerboard

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
strangecargo
Posts: 4
Joined: Sat May 20, 2017 3:13 am

USB audio issues on Asus Tinkerboard

Post by strangecargo »

I recently got an Asus Tinkerboard for, well, tinkering. I tried to use it with a Benchmark DAC3 HGC in UAC2 mode over USB and whenever I try to play back audio (primarily using Roon, but also shairport-sync), audio plays back slightly slower than it should and is heavily distorted, as if there is a buffer constantly underrunning. Here's a post from somebody on the Roon forums that seemed to run into the exact same issue, but managed to solve it by switching to Volumio. I haven't tried that yet (I have a preference for the pared-down nature of DietPi). Where should I start debugging this issue?
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: USB audio issues on Asus Tinkerboard

Post by Fourdee »

strangecargo wrote:I recently got an Asus Tinkerboard for, well, tinkering. I tried to use it with a Benchmark DAC3 HGC in UAC2 mode over USB and whenever I try to play back audio (primarily using Roon, but also shairport-sync), audio plays back slightly slower than it should and is heavily distorted, as if there is a buffer constantly underrunning. Here's a post from somebody on the Roon forums that seemed to run into the exact same issue, but managed to solve it by switching to Volumio. I haven't tried that yet (I have a preference for the pared-down nature of DietPi). Where should I start debugging this issue?
Hi,

The user in Roon thread reports adding dwc_otg.fiq_split_enable=0 resolved the issue.
I believe this may need to go into /boot/hw_intf.conf

We recently updated our ASUS TB image with latest kernel, this "may" resolve the issue, worth a fresh install to test:
http://dietpi.com/downloads/images/Diet ... Jessie).7z

You can check the DietPi image version, you used on this installation, with:

Code: Select all

cat /etc/.dietpi_image_version
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
strangecargo
Posts: 4
Joined: Sat May 20, 2017 3:13 am

Re: USB audio issues on Asus Tinkerboard

Post by strangecargo »

The user in Roon thread reports adding dwc_otg.fiq_split_enable=0 resolved the issue.
I thought this at first, but upon re-reading the post, I think the poster was just doing a poor job of explaining that he got USB audio to work using Volumio, *after* trying a bunch of stuff that he went on to describe that didn't work for him.
We recently updated our ASUS TB image with latest kernel, this "may" resolve the issue, worth a fresh install to test:
http://dietpi.com/downloads/images/Diet ... Jessie).7z
I'll give this a try later today and check back in with results.
strangecargo
Posts: 4
Joined: Sat May 20, 2017 3:13 am

Re: USB audio issues on Asus Tinkerboard

Post by strangecargo »

I just tried out the most recent DietPi build for this board and am still getting the same issue. An additional data point: I also get this same issue when trying to use the USB input with the Asus Tinkerboard on a PS Audio Directstream DAC. Both the DAC3 and the Directstream work perfectly fine when using DietPi on a Raspberry Pi 3.
Post Reply