Problem with SSH

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
corkychaff916

Problem with SSH

Post by corkychaff916 »

Hi, I have a problem when Im trying to connect my RaspberryPi 1 Model B+ with my pc via SSH over WIFI. I put the correct ip and user (root) on Putty or in Kitty but when im going to put de password (dietpi) it says "access denied ". This happens with OpenSSH and Dropbear. I have installed other things, for example, owncloud, wordpress, lxde or Transmission and those work perfectly.

Thanks for all the answers and help.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Problem with SSH

Post by Fourdee »

corkychaff916 wrote:Hi, I have a problem when Im trying to connect my RaspberryPi 1 Model B+ with my pc via SSH over WIFI. I put the correct ip and user (root) on Putty or in Kitty but when im going to put de password (dietpi) it says "access denied ". This happens with OpenSSH and Dropbear. I have installed other things, for example, owncloud, wordpress, lxde or Transmission and those work perfectly.

Thanks for all the answers and help.
Hi,

The default root password for DietPi on all images is dietpi
- Have you changed your root password to something else (eg: dietpi-config > security)?
- Just incase of a typo. Try to copy and paste the password dietpi into the ssh term.
- Did you install dropbear/openssh using dietpi-software?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
corkychaff916

Re: Problem with SSH

Post by corkychaff916 »

Fourdee wrote:
corkychaff916 wrote:Hi, I have a problem when Im trying to connect my RaspberryPi 1 Model B+ with my pc via SSH over WIFI. I put the correct ip and user (root) on Putty or in Kitty but when im going to put de password (dietpi) it says "access denied ". This happens with OpenSSH and Dropbear. I have installed other things, for example, owncloud, wordpress, lxde or Transmission and those work perfectly.

Thanks for all the answers and help.
Hi,

The default root password for DietPi on all images is dietpi
- Have you changed your root password to something else (eg: dietpi-config > security)?
- Just incase of a typo. Try to copy and paste the password dietpi into the ssh term.
- Did you install dropbear/openssh using dietpi-software?
1) Yes, I have change the default password.
2) I also try that.
3) Yes.

User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Problem with SSH

Post by Fourdee »

corkychaff916 wrote: 1) Yes, I have change the default password.
What did you change the password to?

EDIT:

Still cant login?
- Keyboard layout/country (eg: qwerty UK)?
- Have you tried typing in dietpi (or your new password) in SSH as the username to see if it comes out the same?
- Where did you download the image from?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Problem with SSH

Post by Fourdee »

Also,

If you installed OpenSSH manually, without using DietPi-Software, you will need to enable root login on Jessie:

Code: Select all

sed -i '/PermitRootLogin/c\PermitRootLogin yes' /etc/ssh/sshd_config
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
undert0wn
Posts: 2
Joined: Mon May 28, 2018 10:26 pm

Re: Problem with SSH

Post by undert0wn »

The problem is likely that your keyboard settings are wrong and you created a strong password with a character...
The character you are using from SSH does not match what it thinks the password is.

To fix:
1. Log into your Pi locally with a keyboard.
2. Run the dietpi-config command.
3. Navigate to Language/Regional Options.
4. Navigate to Keyboard Change Keyboard Layout Setting.
5. Set your correct keyboard type.
  • Usually defaults to Generic 105-key (Intl) PC, if in US then you may want to use something like Generic 104-key PC instead.
6. Select the correct layout.
  • This usually defaults to English (UK). If you are in the US then you DEFINITELY want to select other and choose English (US) instead.
7. Save settings and reboot.
8. Log in locally again and type out some special characters to verify settings now look correct.
9. If correct, run the passwd command and reset your password.
10. Test via SSH to verify you can now log in with the password you just set.

Hope this helps,

undert0wn
Post Reply