Roon and wifi on Raspberry ver 2B and Edimax EW-7811Un

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
henrylar
Posts: 10
Joined: Sun Jan 15, 2017 3:35 pm

Roon and wifi on Raspberry ver 2B and Edimax EW-7811Un

Post by henrylar »

HI
Dietpi and the Roon client runs fine, and is a breeze to setup. I can make wifi work on Raspberry 3 without problems. I can also make wifi work with the Edimax until I install the Roon client. Then it will not work. I have several boards ver. 2 and Edimax adapters, so I would love to make it work. Any ideas?
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Roon and wifi on Raspberry ver 2B and Edimax EW-7811Un

Post by Fourdee »

henrylar wrote:HI
Dietpi and the Roon client runs fine, and is a breeze to setup. I can make wifi work on Raspberry 3 without problems. I can also make wifi work with the Edimax until I install the Roon client. Then it will not work. I have several boards ver. 2 and Edimax adapters, so I would love to make it work. Any ideas?
Hi,

Lets start by finding out which chipset this runs, then we can see if the driver is supported in RPi kernel/modules.

Please paste results of the following commands, once EW-7811Un is plugged in:

Code: Select all

lsusb
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
henrylar
Posts: 10
Joined: Sun Jan 15, 2017 3:35 pm

Re: Roon and wifi on Raspberry ver 2B and Edimax EW-7811Un

Post by henrylar »

Thank you for the response, but sorry for my ignorance. After SSH' ing the Pi, what do I have to do before writing that?

Here is what I got:

root@DietPi:~# code: select all
-bash: code:: command not found
root@DietPi:~# lsusb
Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@DietPi:~#

After installing the Roon software, it still gets an IP address, but it is useless, it does not connect; I cannot SSH it, and it is not visible in Roon.
As said, before I install Roon, I can get access to SSH ( If I only install DietPi, and with LAN it works flawlessly.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Roon and wifi on Raspberry ver 2B and Edimax EW-7811Un

Post by Fourdee »

henrylar wrote:Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

After installing the Roon software, it still gets an IP address, but it is useless, it does not connect; I cannot SSH it, and it is not visible in Roon.
As said, before I install Roon, I can get access to SSH ( If I only install DietPi, and with LAN it works flawlessly.
I have this exact same adapter, use it for testing.

Just wondering if its a issue with signal strength?

First, make sure you select your country code in dietpi-config > Network > WiFi > Country Code. As this will enable correct (usually higher) antenna power levels and channels.

After that, lets check the signal strength when the connection is "working", and, when you are unable to connect "down":

Code: Select all

iwconfig
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
henrylar
Posts: 10
Joined: Sun Jan 15, 2017 3:35 pm

Re: Roon and wifi on Raspberry ver 2B and Edimax EW-7811Un

Post by henrylar »

Hi Fourdee
I am awfully sorry for having bothered you with this. It seems to be a problem with my router - a restart changed everything.

This is what it now says with the Pi behind two walls from the router - as you can imagine everything works fine now.

root@DietPi:~# iwconfig
wlan0 IEEE 802.11bgn ESSID:"ASUS" Nickname:"<WIFI@REALTEK>"
Mode:Managed Frequency:2.437 GHz Access Point: xxxxxxxxxxx
Bit Rate:72.2 Mb/s Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Encryption key:****-****-****-****-****-****-****-**** Security mode:open
Power Management:off
Link Quality=100/100 Signal level=88/100 Noise level=0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Roon and wifi on Raspberry ver 2B and Edimax EW-7811Un

Post by Fourdee »

henrylar wrote:Hi Fourdee
I am awfully sorry for having bothered you with this. It seems to be a problem with my router - a restart changed everything.
No worries, it happens (even to me the other day lol). Great to hear its all resolved :)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply