https on nextcloud doesn't work..

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
fleaplc
Posts: 14
Joined: Tue Oct 25, 2016 1:23 pm

https on nextcloud doesn't work..

Post by fleaplc »

I've a orange pi board running nextcloud. It works fine, then I'm trying to enable https:// but not work...
I followed this steps:
1-installed and configured no-ip (running dietpi-config I see for NoIP=Online / Active) that's fine
2-http://fuzon.co.uk/phpbb/viewtopic.php? ... art=10#p52 (install certbot and run dietpi-letsencrypt)
3- test my domain on https://www.ssllabs.com/ssltest/analyze.html (successfully)

but if I try to connect to my https://domain.org/nextcloud no way to get it!

any suggestion is appreciated
Last edited by fleaplc on Fri Oct 28, 2016 1:47 pm, edited 1 time in total.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: https on nexcloud doesn't work..

Post by Fourdee »

fleaplc wrote: 3- test my domain on https://www.ssllabs.com/ssltest/analyze.html (successfully)

but if I try to connect to my https://domain.org/nextcloud no way to get it!
Weird, if the SSL test comes back ok, it should be functional.

Does the default website work, eg: https://domain.org ?

Lets take a look at your settings, are you running Lighttpd or Apache2 webserver?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
fleaplc
Posts: 14
Joined: Tue Oct 25, 2016 1:23 pm

Re: https on nextcloud doesn't work..

Post by fleaplc »

the default website is not a "website"... I mean, I'm using dietpi on orange pi pc in my home-lan. Than shared (DMZ) the orange pi to the internet.
With no-ip i get this host: fleacloud.hopto.org (seems works) (and I have a fixed public Ip from my isp)
I'm running apache2
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: https on nextcloud doesn't work..

Post by Fourdee »

fleaplc wrote:the default website is not a "website"... I mean, I'm using dietpi on orange pi pc in my home-lan. Than shared (DMZ) the orange pi to the internet.
With no-ip i get this host: fleacloud.hopto.org (seems works) (and I have a fixed public Ip from my isp)
I'm running apache2
Sorry, i meant the default index.htm page which gets installed by default.

Try connecting to your website without SSL to make sure its accessable externally: Then do the same with SSL: Also, can you paste/upload contents of the following files please:
  • /etc/apache2/apache2.conf
  • /etc/apache2/sites-available/* (eg: all files in this directory)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply