External Hard Drive visible in DietPi but not in Windows 10

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
chonger
Posts: 2
Joined: Mon May 10, 2021 3:35 am

External Hard Drive visible in DietPi but not in Windows 10

Post by chonger »

I have a Seagate 8TB external hard drive that I'm using for media storage. I formatted it as an NTFS drive using dietpi-drive_manager. I mounted the drive to my RPi and I can see it and use it fine on my Pi. No worries there. When I unplug it from my Pi and plug it into my Windows 10 machine, I hear the USB connection sound but it never shows up under "This PC". When I go to Disk Management I DO see the drive but it doesn't have a volume letter and there's no way for me to access it. When I right click the drive, the only option I can select is "Delete volume".
Disk Manager.png
Before I reformatted the drive to be NTFS it was exFAT and I still had the same issue. Has anyone run into this before? I'm planning on sharing this HDD over my home network but I'd like to be able to use it as a USB drive on both Windows and Pi as there will be times that I need to put a large amount of data on it and I'd rather not do that over the network.
User avatar
Joulinar
Posts: 5716
Joined: Sat Nov 16, 2019 12:49 am

Re: External Hard Drive visible in DietPi but not in Windows 10

Post by Joulinar »

Did you tried to format the HDD on Windows and plug it back to DietPi?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
chonger
Posts: 2
Joined: Mon May 10, 2021 3:35 am

Re: External Hard Drive visible in DietPi but not in Windows 10

Post by chonger »

I was trying to avoid doing this because I already started loading up my HDD with movies but I figured I should get this set up correctly from the beginning so this is the route I went. When I reformatted in Windows, I could see the drive in Windows but I couldn't mount it to my Pi. When I would go to drive manager to mount the drive it would just hang on "Detecting drive, please wait...". After waiting a while I just started from scratch and reflashed DietPi and at that point I could mount the drive on my Pi. I'm assuming I'll still be able to see the drive when I plug it into my Windows machine, I'll be checking throughout the process to make sure I can see it on both.
Post Reply