Transparent WIFI to ETH routing via RPi

Guides and tutorials for various stuff. Posted by DietPi users.
Post Reply
Janis
Posts: 28
Joined: Sun Oct 30, 2016 9:42 am

Transparent WIFI to ETH routing via RPi

Post by Janis »

Hi,

Please I need your help.

I have following problem, and wanted to ask your advise how to solve it.
I have BOX that needs access to port the 80 from Internet, but has only Ethernet connectivity.

I would like to use RPi to interconnect WIFI to ETH and have following set-up:

Internet <=> Router @ WIFI <=> WIFI @ RPi @ ETH <=> ETH @ BOX

I found this RPi WIFI to ETH Bridge set-up, and it works.
https://willhaley.com/blog/raspberry-pi ... et-bridge/

I even added fixed IP address assignment BOX, but the problem its that there is other network created by DNSMASQ on RPi for the ETH, and devices on ETH are not accessible from outside Internet or WIFI in first place.

I somehow need either RPi to be fully transparent to access port 80 of the box from outside:
- Is there a solution to create WIFI to ETH Bridge on RPi that is fully transparent - doesn't have own DHCP, and the DHCP which is giving IP address to RPi would also give other IP address to a device connected to the RPi ETH port?
- Is there kind of two level port forwarding possible (one on main router from Internet to RPi and other on RPi from WIFI NW to which RP is connected to ETH NW created under RPi)?
- Or I'm on the wrong way and need to use completely different solution for this problem?

Regards,
Janis

smittyj
Posts: 7
Joined: Wed May 08, 2019 1:05 am

Re: Transparent WIFI to ETH routing via RPi

Post by smittyj »

Linux won't route packets by default, get to the part about "Enabling forwarding in /etc/sysctl.conf" and you should be on your way. You shouldn't need to NAT based on your diagram.

https://arstechnica.com/gadgets/2016/04 ... m-scratch/

Good luck.

skilzor
Posts: 6
Joined: Thu May 07, 2020 9:47 am

Re: Transparent WIFI to ETH routing via RPi

Post by skilzor »

auto lo iface lo inet loopback iface eth0 inet manual auto wlan0 iface wlan0 inet manual auto br0 iface br0 inet dhcp bridge_ports wlan0 eth0 bridge_stp off bridge_fd 0 bridge_waitport 0 wpa-iface wlan0 wpa-connect br0 wpa-ssid "YourWifiSSID" wpa-psk "YourWpaPassphrase" Rebooting in the wake of setting this design, no DHCP address is pulled by br0. As indicated by iwconfig, wlan0 is related with the base station. Setting br0 to a static location gives it an IP, however there's no availability (can't ping the passage, despite the fact that ip course shows the right course).


Post Reply