Problems accessing TasmoAdmin Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

still pihole answering :(

//
websrv4.jpg
User avatar
Joulinar
Posts: 3340
Joined: Sat Nov 16, 2019 12:49 am

Re: Problems accessing TasmoAdmin

Post by Joulinar »

pls share your config file

Code: Select all

cat /etc/lighttpd/lighttpd.conf
There is no need to do screen prints. You can simple copy you SSH output as txt
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

now everything is dead.
websrv5.jpg
websrv6.jpg
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

now config file isn't found
User avatar
Joulinar
Posts: 3340
Joined: Sat Nov 16, 2019 12:49 am

Re: Problems accessing TasmoAdmin

Post by Joulinar »

did you removed? Ok let's create a new one

Code: Select all

nano /etc/lighttpd/lighttpd.conf
An empty file shoud open now. copy all of the following. Use the Select all button

Code: Select all

server.modules = (
        "mod_indexfile",
        "mod_setenv",
        "mod_access",
        "mod_alias",
        "mod_redirect",
        "mod_accesslog",
)

server.document-root        = "/var/www"
server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.errorlog             = "/var/log/lighttpd/error.log"
server.pid-file             = "/var/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"
server.port                 = 80
accesslog.filename          = "/var/log/lighttpd/access.log"

# strict parsing and normalization of URL for consistency and security
# https://redmine.lighttpd.net/projects/lighttpd/wiki/Server_http-parseoptsDetails
# (might need to explicitly set "url-path-2f-decode" = "disable"
#  if a specific application is encoding URLs inside url-path)
server.http-parseopts = (
  "header-strict"           => "enable",# default
  "host-strict"             => "enable",# default
  "host-normalize"          => "enable",# default
  "url-normalize-unreserved"=> "enable",# recommended highly
  "url-normalize-required"  => "enable",# recommended
  "url-ctrls-reject"        => "enable",# recommended
  "url-path-2f-decode"      => "enable",# recommended highly (unless breaks app)
 #"url-path-2f-reject"      => "enable",
  "url-path-dotseg-remove"  => "enable",# recommended highly (unless breaks app)
 #"url-path-dotseg-reject"  => "enable",
 #"url-query-20-plus"       => "enable",# consistency in query string
)

index-file.names            = ( "index.php", "index.html" )
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )

# default listening port for IPv6 falls back to the IPv4 port
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.conf.pl"
include "/etc/lighttpd/conf-enabled/*.conf"

#server.compat-module-load   = "disable"
server.modules += (
        "mod_compress",
        "mod_dirlisting",
        "mod_staticfile",
)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

created the file.

[?1l>root@DietPi:~# systemctl restart lighttpd.service
Job for lighttpd.service failed because the control process exited with error code.
See "systemctl status lighttpd.service" and "journalctl -xe" for details.
root@DietPi:~# systemctl status lighthh[Kttpd.service
Unit lighthttpd.service could not be found.
root@DietPi:~# systemctl status lighthttpd.service
Unit lighthttpd.service could not be found.
User avatar
Joulinar
Posts: 3340
Joined: Sat Nov 16, 2019 12:49 am

Re: Problems accessing TasmoAdmin

Post by Joulinar »

be careful. there are typos on your status command it is systemctl status lighttpd.service

let's try to verify whats wrong

Code: Select all

/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

sorry, ssh output wasn't working.

//

Code: Select all

[0;1;31m●[0m lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; disabled; vendor preset: enabled)
   Active: [0;1;31mfailed[0m (Result: exit-code) since Wed 2020-12-30 22:47:37 GMT; 9min ago
  Process: 814 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf [0;1;31m(code=exited, status=255/EXCEPTION)[0m

Dez 30 22:47:37 DietPi systemd[1]: lighttpd.service: Service RestartSec=100ms expired, scheduling restart.
Dez 30 22:47:37 DietPi systemd[1]: lighttpd.service: Scheduled restart job, restart counter is at 5.
Dez 30 22:47:37 DietPi systemd[1]: Stopped Lighttpd Daemon.
Dez 30 22:47:37 DietPi systemd[1]: [0;1;39m[0;1;31m[0;1;39mlighttpd.service: Start request repeated too quickly.[0m
Dez 30 22:47:37 DietPi systemd[1]: [0;1;39m[0;1;31m[0;1;39mlighttpd.service: Failed with result 'exit-code'.[0m
Dez 30 22:47:37 DietPi systemd[1]: [0;1;31m[0;1;39m[0;1;31mFailed to start Lighttpd Daemon.[0m
root@DietPi:~# 
User avatar
Joulinar
Posts: 3340
Joined: Sat Nov 16, 2019 12:49 am

Re: Problems accessing TasmoAdmin

Post by Joulinar »

pls test the configuration

Code: Select all

/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
UsAs
Posts: 22
Joined: Wed Dec 30, 2020 10:29 pm

Re: Problems accessing TasmoAdmin

Post by UsAs »

Code: Select all

root@DietPi:~# /usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf
2020-12-30 22:58:50: (configfile.c.1296) source: /etc/lighttpd/lighttpd.conf line: 2 pos: 30 parser failed somehow near here: url-path-dotseg-remove 
root@DietPi:~# 
Post Reply