Page 1 of 1

help "apt-get failed"

Posted: Sun Mar 19, 2017 2:16 am
by syl3nt
I made the first boot, it upgraded, and then after selecting the software i wanted to install , i left it all alone installing and 10 min after i went check it out and the terminal was like this, i never faced it , so i don't know what to do

Re: help "apt-get failed"

Posted: Sun Mar 19, 2017 11:50 am
by k-plan
syl3nt wrote:I made the first boot, ...
On which device, such as RPI3 for example?

Can you please share:

Code: Select all

cat /var/log/dietpi-software_apt.log

Re: help "apt-get failed"

Posted: Sun Mar 19, 2017 3:37 pm
by syl3nt
i am using an orange pi pc
i am afraid i can't share it, because it has nothing there ..
i think it wiped out because i went to bed and i powerd it off and this morning, i made exactly the same steps, to install the same things, and it was perfectly ok ..
i think it was the internet connection but i am not 100% sure, my second access point was kind off faulty and i rebooted it before i powered the orangepi this morning so.. that could've been it, just a failure to retrieve apt mirror info, no ?

Re: help "apt-get failed"

Posted: Mon Mar 20, 2017 3:35 pm
by Sciamano
I'm not sure what causes this, but I have noticed that "Error 100's" happen a lot on the OPi PC, especially immediately after the first installation.
I have personally posted about this at least twice. Usually launching the command again is enough to solve the problem.
I'm totally speculating here, but I have the impression that the first time the system updates the apt lists ('apt-get update') something goes wrong and it shows when trying to install the first package.

Re: help "apt-get failed"

Posted: Mon Mar 20, 2017 5:21 pm
by syl3nt
Then it is just it(dont know if hardware or software) failing on getting an internet connection
can be something to do with it, isnt it possible to be getting an ip of my local lan and not be advertising to the router, and as such it doesnt recognize as a online machine or something ?
i say this because it wasnt appearing on the router, i had to go by hand from my local ips(fisrt 10 until i got it) to connect through ssh

Re: help "apt-get failed"

Posted: Mon Mar 20, 2017 6:17 pm
by Fourdee
Hi guys,

i'll run a test on OPi PC here, see if we can replicate the issue experienced. If not, its most likley an issue with internet, either at the users end, or hardware/driver on the OPi.

Re: help "apt-get failed"

Posted: Mon Mar 20, 2017 7:08 pm
by Fourdee
Fourdee wrote:Hi guys,

i'll run a test on OPi PC here, see if we can replicate the issue experienced. If not, its most likley an issue with internet, either at the users end, or hardware/driver on the OPi.
Ok, fresh DietPi install (DietPi_v145_OrangePiPC-armv7-(Jessie).img):
- Logging mode > Full
- SSH server > OpenSSH
- Go >> start install

No issues. Unable to replicate.

As K-Plan already mentioned, DietPi generates a log file with more information on why APT failed. We will need this information, after the issue occurs to debug this correctly:
http://dietpi.com/phpbb/viewtopic.php?f ... 6251#p6219