Failed to upgrade from Debian Buster to Bullseye

Having issues with your DietPi installation or found a bug? Post it here.
User avatar
Joulinar
Posts: 5998
Joined: Sat Nov 16, 2019 12:49 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by Joulinar »

does FroFTP completed now? Because you stated there are some issues with?

could you run apt update && apt upgrade and poste the output
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

I uninstalled Proftpd before upgrading to Bullseye. So didn't face that issue.
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

This did the trick and solved the issue.

Code: Select all

apt install gcc-8-base
Doing a full upgrade now. Will update you if I come across any issues. Fingers crossed :P
User avatar
Joulinar
Posts: 5998
Joined: Sat Nov 16, 2019 12:49 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by Joulinar »

yes there is a setting in ProFTP config file that would need to be changes before. Basically not a big deal :)

Code: Select all

sed -i '/IdentLookups/c\<IfModule mod_ident.c>\nIdentLookups off\n</IfModule>' /etc/proftpd/proftpd.conf
On new installations we already have that implemented with DietPi 7.5. I guess the blog would need to be extended by this as well.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

Successfully migrated to Bullyseye. Facing issue with lighttpd

Code: Select all

/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf
2021-09-16 17:12:52: plugin.c.195) dlopen() failed for: /usr/lib/lighttpd/mod_openssl.so /usr/lib/lighttpd/mod_openssl.so: cannot open shared object file: No such file or directory
2021-09-16 17:12:52: server.c.1238) loading plugins finally failed
It has to do with SSL configured. I don't seem to have this module "mod_openssl.so". Has something changed in Bullseye?
alleyu2
Posts: 20
Joined: Sun May 03, 2020 8:52 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by alleyu2 »

this worked

Code: Select all

 apt install lighttpd-mod-openssl
User avatar
Joulinar
Posts: 5998
Joined: Sat Nov 16, 2019 12:49 am

Re: Failed to upgrade from Debian Buster to Bullseye

Post by Joulinar »

Yes this is required now
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply