Kodi Error

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
nikos73
Posts: 8
Joined: Wed Sep 08, 2021 1:04 am

Kodi Error

Post by nikos73 »

In a new install of dietpi from the arm7 32bit bullseye image to a Raspberry pi2, after Kodi installation using the dietpi-software, it will not autostart and in the command line a startkodi returns:

failed to open zone.tab
ERROR: Unable to create GUI. Exiting

Any ideas what I should fix?
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Kodi Error

Post by Joulinar »

hi,

can you share your DietPi version? Are you on latest 7.5? can you share as well following.

Code: Select all

echo $G_DISTRO_NAME $G_RASPBIAN
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
nikos73
Posts: 8
Joined: Wed Sep 08, 2021 1:04 am

Re: Kodi Error

Post by nikos73 »

Dietpi version is 7.5.2.

root@DietPi:~# echo $G_DISTRO_NAME $G_RASPBIAN
bullseye 0

After some fiddling around mainly with display settings and memory split now Kodi starts but with the following errors:

Code: Select all

root@DietPi:~# startkodi
failed to open zone.tab
libva info: VA-API version 1.10.0
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Kodi Error

Post by Joulinar »

@MichaIng
could you have a look pls
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3216
Joined: Sat Nov 18, 2017 6:21 pm

Re: Kodi Error

Post by MichaIng »

Could you show which Kodi version/package is installed?

Code: Select all

apt policy kodi
apt policy kodi-bin
User avatar
MichaIng
Site Admin
Posts: 3216
Joined: Sat Nov 18, 2017 6:21 pm

Re: Kodi Error

Post by MichaIng »

Okay, on the ARMv7 image, the Debian Kodi package is pulled, while we have an own RPi accelerated one. We changed it so that the ARMv7 image is pulls our package as well: https://github.com/MichaIng/DietPi/pull/4719

Sadly, while testing, we recognised that RPi just a few hours ago released new libraspberrypi packages with a breaking change, so that our Kodi build does not find the contained libraries anymore (those are now on a different location) :(. I'll recompile it and let you know once done.
nikos73
Posts: 8
Joined: Wed Sep 08, 2021 1:04 am

Re: Kodi Error

Post by nikos73 »

Indeed the Debian Kodi is installed:

Code: Select all

root@DietPi:~# apt policy kodi
kodi:
  Installed: 2:19.1+dfsg2-2
  Candidate: 2:19.1+dfsg2-2
  Version table:
 *** 2:19.1+dfsg2-2 500
        500 https://deb.debian.org/debian bullseye/main armhf Packages
        100 /var/lib/dpkg/status
root@DietPi:~# apt policy kodi-bin
kodi-bin:
  Installed: 2:19.1+dfsg2-2
  Candidate: 2:19.1+dfsg2-2
  Version table:
 *** 2:19.1+dfsg2-2 500
        500 https://deb.debian.org/debian bullseye/main armhf Packages
        100 /var/lib/dpkg/status
Today there were some updates that dietpi invited me to apt upgrade:

Code: Select all

apt upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  libatomic1 libepoxy0
The following packages will be upgraded:
  ffmpeg libavcodec58 libavdevice58 libavfilter7 libavformat58 libavresample4
  libavutil56 libc-bin libc-l10n libc6 libegl-mesa0 libgbm1 libgl1-mesa-dri
  libglapi-mesa libglx-mesa0 libpostproc55 libraspberrypi-bin libraspberrypi0
  libswresample3 libswscale5 locales
21 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 29.8 MB of archives.
After this operation, 28.0 MB of additional disk space will be used.
After those library updates Kodi will not start at all, as @Joulinar correctly noticed in GitHub:

Code: Select all

root@DietPi:~# startkodi
/usr/lib/arm-linux-gnueabihf/kodi/kodi.bin: error while loading shared libraries: libmmal_core.so: cannot open shared object file: No such file or directory
User avatar
Joulinar
Posts: 5619
Joined: Sat Nov 16, 2019 12:49 am

Re: Kodi Error

Post by Joulinar »

yes because RPi devs released a new version of libraspberrypi0 package. This update changed location of shared libraries dramatically and thinks like kodi would need to be compiled again against this new directory structure. This is valid for our own kodi package (I'm using) and I guess for the official kodi package (you are using).

For the time being, there is nothing we can do except waiting on a new kodi version becoming available. At least for our package @MichaIng will work on this. But compiling the package is taking time.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3216
Joined: Sat Nov 18, 2017 6:21 pm

Re: Kodi Error

Post by MichaIng »

Try this one:

Code: Select all

cd /tmp
curl -sSfLO https://dietpi.com/downloads/binaries/bullseye/kodi_armv7l.deb
apt install ./kodi_armv7l.deb libraspberrypi0
rm kodi_armv7l.deb
Post Reply