Shairport and USB DAC's Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
Hammer
Posts: 31
Joined: Fri Apr 20, 2018 5:14 pm

Shairport and USB DAC's

Post by Hammer »

Hi, I'm trying to use Shairport with my USB DAC. Using aplay -l, I see that it is hw:1 and so in /usr/local/etc/shairport-sync.conf, I added the following under alsa:

alsa =
{
output_device = "hw:1";
output_rate = 44100;
output_format = "S32";
// mixer_control_name = "PCM";
// output_rate = 44100; // can be 44100, 88200, 176400 or 352800
// output_format = "S16"; // can be "U8", "S8", "S16", "S24", "S24_3LE", "S24_$
};

However, when I play, I do not get any sound. Doing some googling, I see that output_format has to be supported by my DAC (Auralic Vega) and through trial and error, I think S32 is supported because when I try the other settings, when I play and so a systemctl status shairport-sync -l, I see error messages and when I use S32, I don't get an error message.

However, I am still not getting any sound. I will note the HQplayer NAA and Raspotify play fine and I get sound.

Any thoughts would be greatly appreciated! Thank you!
Hammer
Posts: 31
Joined: Fri Apr 20, 2018 5:14 pm

Re: Shairport and USB DAC's

Post by Hammer »

Hi, as a follow up, I also tried "plughw:1". This worked for Raspotify, but alas, not with shairpot-sync.

Thanks!
Hammer
Posts: 31
Joined: Fri Apr 20, 2018 5:14 pm

Re: Shairport and USB DAC's

Post by Hammer »

Hi, for those who are having the same issue, I followed these instructions to install the latest version and it now works! I changed device to hw:1 for my usb DAC. Thank you!

https://gist.github.com/connorjan/984e6 ... 0eb5724b82
Post Reply