nanopi M1 cannot start lxde

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
hatahata
Posts: 26
Joined: Thu Jul 07, 2016 3:42 am

nanopi M1 cannot start lxde

Post by hatahata »

hi all .

nanopi M1 cannot start lxde .

i have done the followings .

1)slim
/etc/slim.conf
default_path /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
default_xserver /usr/bin/X11/X
xserver_arguments -nolisten tcp
halt_cmd /sbin/shutdown -h now
reboot_cmd /sbin/shutdown -r now
console_cmd /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue.net; exec /bin/login"
xauth_path /usr/bin/X11/xauth
authfile /var/run/slim.auth
login_cmd exec /bin/bash -login /etc/X11/Xsession %session
sessiondir /usr/share/xsessions/
screenshot_cmd scrot /root/slim.png
welcome_msg Welcome to %host
shutdown_msg The system is halting...
reboot_msg The system is rebooting...
default_user root
auto_login yes
current_theme debian-lines
lockfile /var/run/slim.lock
logfile /var/log/slim.log


2)/root/.xinitrc
startlxde


3)dpkg -l

3-A)dpkg -l | grep xorg
ii xserver-xorg 1:7.7+7 armhf X.Org X server
ii xserver-xorg-core 2:1.16.4-1 armhf Xorg X server - core server
ii xserver-xorg-input-all 1:7.7+7 armhf X.Org X server -- input driver metapackage
ii xserver-xorg-input-evdev 1:2.9.0-2 armhf X.Org X server -- evdev input driver
ii xserver-xorg-input-synaptics 1.8.1-1 armhf Synaptics TouchPad driver for X.Org server
ii xserver-xorg-video-all 1:7.7+7 armhf X.Org X server -- output driver metapackage
ii xserver-xorg-video-ati 1:7.5.0-1 armhf X.Org X server -- AMD/ATI display driver wrapper
ii xserver-xorg-video-fbdev 1:0.4.4-1+b2 armhf X.Org X server -- fbdev display driver
ii xserver-xorg-video-mach64 6.9.4-2 armhf X.Org X server -- ATI Mach64 display driver
ii xserver-xorg-video-modesetting 0.9.0-2 armhf X.Org X server -- Generic modesetting driver
ii xserver-xorg-video-nouveau 1:1.0.11-1 armhf X.Org X server -- Nouveau display driver
ii xserver-xorg-video-r128 6.9.2-1+b2 armhf X.Org X server -- ATI r128 display driver
ii xserver-xorg-video-radeon 1:7.5.0-1 armhf X.Org X server -- AMD/ATI Radeon display driver
ii xserver-xorg-video-vesa 1:2.3.3-1+b3 armhf X.Org X server -- VESA display driver

3-B)dpkg -l | grep lxde
ii lxde 6 all Metapackage for LXDE
ii lxde-common 0.99.0-1 all LXDE configuration data
ii lxde-core 6 all Metapackage for the LXDE core
ii lxde-icon-theme 0.5.1-1 all LXDE standard icon theme

3-c) dpkg -l | grep xinit
ii xinit 1.3.4-1 armhf X server initialisation tool

---------------------
regards
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: nanopi M1 cannot start lxde

Post by Fourdee »

Hi,

NanoPi M1 GPU features are disabled and unsupported at this time on all H3 boards. Our image is ideal for server usage. You should be able to run a desktop under VNC, but not native.

GPU features are supported in:
- RPi (all)
- Odroid (all)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
hatahata
Posts: 26
Joined: Thu Jul 07, 2016 3:42 am

Re: nanopi M1 cannot start lxde

Post by hatahata »

thanks for kind advice .

now i use banana pi M1 as internet web and ssh server because of low maintenance cost .
when banana pi will became broken , i will use nanopi as internet web and ssh server .

without your advice , A wasteful effort are repeated.
---
regards
Post Reply