GPU/RAM Memory Split on Raspberry Pi 4 4GB Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
DietCH
Posts: 12
Joined: Tue May 12, 2020 10:15 am

GPU/RAM Memory Split on Raspberry Pi 4 4GB

Post by DietCH »

hi,

I noticed that when I was setting up DietPi on my RPi 4 (4GB model), it will not allow me to choose anything.
It always defaults back to 16: Server

Is this an known bug?

-Daniel
DietCH
Posts: 12
Joined: Tue May 12, 2020 10:15 am

Re: GPU/RAM Memory Split on Raspberry Pi 4 4GB

Post by DietCH »

OK, nevermind, I just found a workaround:

add this line in /boot/config.txt under the GPU memory splits section:

Code: Select all

gpu_mem_4096=320
User avatar
Joulinar
Posts: 2588
Joined: Sat Nov 16, 2019 12:49 am

Re: GPU/RAM Memory Split on Raspberry Pi 4 4GB

Post by Joulinar »

Hi,

many thanks for your report. Indeed you already found the correct setting. If you use dietpi-software to install some application, gpu_mem will be set automatically according best practice. Below an example from an instillation

Code: Select all

[ SUB1 ] DietPi-Set_hardware > gpumemsplit (64)
[  OK  ] DietPi-Set_hardware | Setting in /boot/config.txt adjusted: gpu_mem_1024=64
[  OK  ] DietPi-Set_hardware | Setting in /boot/config.txt adjusted: gpu_mem_512=64
[  OK  ] DietPi-Set_hardware | Setting in /boot/config.txt adjusted: gpu_mem_256=64
[  OK  ] gpumemsplit 64 | Completed
However you could set it manually on your needs as well.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply