Update | RPi Stretch image is now default with DietPi v159

Hi all,

Update :

(10-12-2017)

https://github.com/Fourdee/DietPi/issues/475#issuecomment-350519670

(edit by k-plan)




We are releasing RPi Stretch image under Beta:
We are looking for users to assist us with tracking possible bugs/issues with the Stretch distro. Please report any issues in this thread.

Stretch benefits from more recent programs, such as:

  • PHP 7.0
  • More up to date versions of software (eg: desktops)
  • Generally speaking, a more updated and recent OS, compared to Jessie.

Why now?
To prep DietPi and its sourecode for Stretch’s arrival, and, to offer our users more up to date software installations.

Please see here for further info and DL link:
https://github.com/Fourdee/DietPi/issues/475#issue-171250292

Hi Fourdee,

Done. Install on RPI Zero:

root@ZeroPi:~# /DietPi/dietpi/misc/rpi_boardinfo

  - RPi Board Info -
 Revision         |     900093
 Released         |     Q2 2016
 Model            |     Zero
 Memory           |     512 MB
 Manufacturer     |     Sony

root@ZeroPi:~# uname -a
Linux ZeroPi 4.4.34+ #930 Wed Nov 23 15:12:30 GMT 2016 armv6l GNU/Linux

161210-0003.gif
Install some software for testing (things, that I normaly use on every DietPi devices):

root@ZeroPi:~# dietpi-software list | grep '[[:space:]]=2'
id 3 | =2 | mc: midnight commander, powerful file manager |
id 12 | =2 | iperf: internet protocol bandwidth measuring tool |
id 13 | =2 | mtr-tiny: full screen ncurses traceroute tool |
id 15 | =2 | tcpdump: command-line network traffic analyzer |
id 17 | =2 | git client: git clone etc |
id 66 | =2 | rpi-monitor: web interface system stats |
id 84 | =2 | lighttpd: webserver | 
id 89 | =2 | php: webserver | 
id 93 | =2 | pi-hole: block adverts for any device on your network | +git +webserver |
id 102 | =2 | rsyslog: system logging |
id 103 | =2 | dietpi-ramlog: minimal, optimized logging | 
id 104 | =2 | dropbear: ssh server |
id 117 | =2 | pivpn: openvpn installer & management tool | +rsyslog

PiVPN:

root@ZeroPi:~# dietpi-services restart

 DietPi-Services
─────────────────────────────────────────────────────
 Mode: restart
 Please wait...

 [Ok] cron
 [Ok] lighttpd
 [Ok] dnsmasq
 [Ok] openvpn

Testing SD-Card overclocking:

  • works great and preformance improvement

But it can be messured with dietpi-config (only sec. will be displayed)

Before:
161210-0001.gif
After:
161210-0007.gif
This is the only “really” DietPi Bug i have noticed.


Sorry, but for me this really cool dropbear feature will not work.
Have I missed something?

Edit:
seem it will only working with WinSCP (only with SCP), not with Fugo, FileZilla, or similar SFTP clients on Mac OSX …

root@ZeroPi:~# dropbear -V
Dropbear v2016.74

Hi Fourdee,

tested Stretch on RPi Zero with same installation updated to the new DietPi v.140 :

 ───────────────────────────────────────
 DietPi     | 20:57 | Wed 21/12/16
 ───────────────────────────────────────
 V140       | RPi Zero (armv6l)
 ───────────────────────────────────────

With apt-get upgrade come as well a new kernel, new Firmware, new RPi bootloader and overlays update with some new overlays.
Could be good, you have a look on it. (eg. enc28j60-spi2.dtbo, i2c-rtc.dtbo, i2c-sensor.dtbo, pisound.dtbo)

root@ZeroPi:~# uname -a
Linux ZeroPi 4.4.38+ #938 Thu Dec 15 15:17:54 GMT 2016 armv6l GNU/Linux

161221-0007.gif
And with v.140 we get some nice fixes. Thanks!

RPi-Monitor:

  • service is now in dietpi-services
root@ZeroPi:~# dietpi-services restart

 DietPi-Services
─────────────────────────────────────────────────────
 Mode: restart
 Please wait...

 [Ok] cron
 [Ok] lighttpd
 [Ok] dnsmasq
 [Ok] openvpn
 [Ok] rpimonitor

Filesystem Benchmark now have correct value:
161221-0003.gif

And first time have the possibility, to test Pi-Hole build-in update feature:
161221-0004.gif

root@ZeroPi:~# pihole -up
::: Checking for updates...

Pi-Hole version update works …
161221-0006.gif
… but not Web Interface Version update:

root@ZeroPi:~# pihole -up
::: Checking for updates...
:::
::: Pi-hole version is v2.10 (Latest version is v2.10)
::: Web Admin version is v1.4.4.2 (Latest version is v2.0)
:::
::: Pi-hole Web Admin files out of date
:::
::: Checking for existing repository...
:::    Checking /var/www/html/admin is a repo... OK!
:::     Updating repo in /var/www/html/admin... [/]

... 

Abbruch                                                 done!
:::
::: Web Admin version is now at v1.4.4.2
::: If you had made any changes in '/var/www/html/admin', they have been stashed using 'git stash'

overlays update with some new overlays.
Could be good, you have a look on it. (eg. enc28j60-spi2.dtbo, i2c-rtc.dtbo, i2c-sensor.dtbo, pisound.dtbo)

Thanks K-Plan, really appreciate the in-depth testing!

Overlay update! Always a good way to see what new HATs (mostly soundcards) are coming to market :smiley:. I’ll take a look at the new .dtb.

pisound.dtbo = Blokas Labs pisound card

https://github.com/raspberrypi/firmware/blob/6d45dcf869688163fa1c745cb059b14baf61b8fd/boot/overlays/README#L835-L838
http://blokas.io/
http://wiki.blokas.io/index.php/pisound
Interesting :smiley:

So I tried the image and some additional software - only for tryout. The packages I’ve installed are only for tryout.

  1. Performance Options: performance
  2. Swap 1000MB
  3. Update firmware
  4. Language an Regional Options
    a. Locale: add de_AT.UTF-8 UTF-8
    b. Timezone: Europe → Vienna
    c. Keyboard Change → NOT WORK NOW - nothing happens
  5. Install:
    a. 68 - Waved
    b. 122 - Node-Red (some Errors/Warnings during installation)
    c.

    d.
    5d.png
    e. 123 - Mosquitto
    f. 117 - PiVPN (same Error as k-plan)
    g. 66 - Rpi Monitor (Bug see below)
    h. 42 - PlexMediaServer
    i. 3 - MC
  6. OpenSSHSambaApache2
  7. Test SDCard overclocking: → fantastic
    a.
    7a.png
    b.
    7b.png
  8. Try to activate OnBoardWiFi - not found
    a.
    8a.png
    Continue next post …
  1. Try to activate OnBoard-Bluetooth
    a.
    9a.png

10.png
11)
11.png
12) Rpi Monitor bug
a.
12a.png
13) Testing Weaved - OK
a.


14) Samba - Works fine
15) PlexMediaServer - runs ok (in this case I’ve tried not direct trancoding; but I tried the website of plex for indirect connection to xu4 plex incl. transcoding via weaved)
16) I’ve sent a bugreport: may there are futher infos in there: Reference CODE: ade76c14-b21a-4c67-be49-fe7412a49097-0

have a nice day.
greets luzi

p.s. if u have a c2 or xu4 Image so i can try this also.

Can i install the stretch img to xu4?
I have burned the emmc sa i do all the times but when i boot nothing appears on screen.And there is no booini file to change from hdmi to vdi as i do at the jessy img.How can i fix this?
Thank you.

No, DietPi Debian Stretch image is at the moment ONLY for RaspBerry Pi (RPis) devices …

Thanks alot.I will do ti now at my RP3

I just wanted to say that I have installed at the Rp3 with https and owncloud server and it is so so good working.It is amazing that the operation system software can make such a big deferred with the same hardware.Later at night I will try to my fist Rp1 512 ram.

Trying this on Rpi3 - mostly OK so far - Syncthing, Webmin, PhpMyAdmin, NoIP, LLMP, NextCLoud -but no wifi - is support for this likely to be far away?

Hi John,

Onboard RPi 3 WiFi is fixed in v142 update.

Can be manually patched now with:

apt-get update
apt-get dist-upgrade -y
wget https://raw.githubusercontent.com/RPi-Distro/firmware-nonfree/master/brcm80211/brcm/brcmfmac43430-sdio.txt -O /lib/firmware/brcm/brcmfmac43430-sdio.txt
reboot

apt-get update
apt-get dist-upgrade -y
wget > https://raw.githubusercontent.com/RPi-Distro/firmware-nonfree/master/brcm80211/brcm/brcmfmac43430-sdio.txt > -O /lib/firmware/brcm/brcmfmac43430-sdio.txt
reboot

Hi Fourdee,

Tried this but still get the message about no wireless hardware found.

John

Hi John,

Apologies, must of been something I missed in patch notes. I just tried a install of the testing v142 branch, WiFi is fully functional.

Looking to release v142 today/tomorrow, if you get a chance after you’ve updated, please let me know if the problem is resolved.

Hi Fourdee,

Getting there testing the wifi but am I right in thinking that this release blocks SSH connections unless you put a file on the boot partition called “ssh”?

John

Edit - WiFi good and added the PiCam software - working fine also.

Hi John,

Not that i’am aware of :slight_smile:

Edit - WiFi good and added the PiCam software - working fine also.

Excellent, thanks for letting me know :slight_smile:

Hi Fourdee,

The wifi stopped working I am afraid - I wasn’t doing much with this device so didn’t notice. I can set it up, it appears to be connected, but on reboot - the wifi connection is not active. Upgraded to v143 - just the same.

Any way to troubleshoot this?

John

Hi John,

We had an issue with the DietPi kernel in v143, lacked firmware for USB WiFi and onboard WiFi.

Please can you run the command in the link below. This will update the kernel and included firmware, reboot and see if the problem persists?
https://github.com/Fourdee/DietPi/issues/741#issuecomment-276087954

Hi Fourdee,

Did as suggested - no luck. Running dietpi-config and connecting wifi it looks as if it is connected. Reboot, it isn’t. Did this several times same result.

John