Problems accessing TasmoAdmin

Hey folks,

i’m a basic dietpi user and i need help.

i installed TasmoAdmin over the preconfigured software installer.

everything went normal.

How do i access TasmoAdmin?

referring to this url, it shoult be: http://<your_IP/domain>/tasmoadmin

https://dietpi.com/forum/t/dietpi-software-details-for-all-installation-options/22/131

what is meant by “domain”?

i’m using pihole on the same server if it’s useful for this case.

Thanks, appreciate your help!


Cheers, UsAs

Hi,

many thanks for your message. That’s a placeholder and would need to be replaced by your local IP address of the DietPi device. https://dietpi.com/docs/software/home_automation/#tasmoadmin

many thanks for your answer!

i tried varoius urls, including the ports.

seems like webserver isn’t listening to the port.

//

seems like webserver refuses the connection.

any chance of troubleshooting for me?

there is no port to add. It’s simply the ip like http:///tasmoadmin

when entering the url, pihole shows up.

did you add /tasmoadmin behind the IP?

yup, i did. pihole is answering.

can you share your web server root directory

ls -la /var/www

sure!

appreciate your help!
www.jpg

what web server you are running?

everything pre installed by pihole.

how can i take a look?

lighttpd

you can check the LISTEN ports, This will show the web server

ss -tulpn | grep LISTEN

Btw: how did you install PiHole? did you used dietpi-software or something else?

yup. used dietpi-software :slight_smile:

//

di you have running something like pihole -r in past? And pls check for the LISTEN ports

a few month ago i had to repair pihole, yes.

then i had to use -r.

ok that might be the issue. pihole -r will offer 2 options. If you choose wrong one, it will replace DietPi configs with a pure PiHole web server config, leading to such effect. If you are using standard, you should be running lighttpd web server. Pls can you post following

ls -la /etc/lighttpd/

sure.
websrv2.jpg

i even used tuya-convert today. but i don’t know if it’s usinf lighttpd.

yep PiHole has overwritten our config file. Try following to fix

cd /etc/lighttpd/
mv lighttpd.conf lighttpd.conf.hole
mv lighttpd.conf.orig lighttpd.conf
systemctl restart lighttpd.service