Native PC for UEFI ver6.0 Error [SOLVED]

I tried following the steps to download the image, install on a USB drive via Rufus to the letter.

However I get a unbootable USB drive.

Is there a step missing? I did see the image had Clonezilla in it, was that supposed to be used at some point?

BTW, I did edit the three files to include sda instead of the mmcblk0.

Can anyone shed some light on what I am doing wrong?

Thank you in advance

There is a new non-beta version of this out you should find it in the downloads:

What are you trying to install on?


Sorry for my misleading title.

Yes it was the new 6.0 version

The computer was a ASRock B85M-ITX LGA1150.

These are the steps

Step 1: Download Rufus and DietPi
Download Rufus
Download the DietPi ISO image (with CloneZilla bundled)
Step 2: Use Rufus to write the ISO | @sal666 Clonezilla installer
Run Rufus
Under Partition scheme, select GPT partition scheme for UEFI
Select the DietPi .iso image
Click start to write the DietPi image
NB: This ISO is for EMMC devices (eg: Z83-II) However, you can edit the following files for non-EMMC devices:
Edit /EFI/boot/grub.cfg, /syslinux/isolinux.cfg and /syslinux/syslinux.cfg and replace mmcblk0 with the name of your target hard disk, eg sda sdb etc.
NOTE: I did this edit after I used Rufus to flash the USB drive then proceeded to step 3.
Step 3: Install DietPi image onto device
Power on the device with USB pen drive attached


I’ve attached option to install mmc or sda. Please extract to the USB DietPi installer, prior to running on SBC.

This is untested, please use only in testing environment.
mmc_sda.7z (1.57 MB)

I apologize greatly.

But when you say extract to the Dietpi installer do you mean extract the file into the DietPi_v6.0_NativePC-EFI-x86_64-Stretch_mmc.iso file, before I try to flash it to a USB? Or do I extract this into the iso ‘after’ I use the installer.

For example:
Rufus flash to USB, extract file into ‘flashed’ USB, then reboot.

I don’t understand.

Not your fault, I failed to explain it fully :slight_smile:

  • Use Rufus to write the image as per the online doc
  • Once the image write is completed, and before you plug USB into SBC, extract the contents of the attachment to the USB pen drive (overwrite existing files/folders).
  • Eject, plug into SBC, power on.
  • You’ll need to ensure the target USB device is sda and the USB installer is sdb. This depends on the BIOS and ports used (No way to know, that I can think of). Therefore, If the install fails to unmount, rewrite the image using Rufus again and swap the USB drives over on SBC.
  • Select Install DietPi sda.


Thank you… :smiley:

Its up and running.

Thanks a lot Fourdee!! :smiley:

Interesting notes:
The SSD had to be larger than 31G or it refused to write. No problem I just used a bigger SSD and the install proceeded.
Also when using the Singxer F1 USB/COAX converter. I had to select usb:dac in order to stream out in 32Bit. After selecting usb-dac I had to update the asound.conf file to the correct card. Worked not problem.
****Otherwise it would only let me stream out in 16bit

Great to hear, thanks for letting us know.

I’ll update our main image download with the new selections.

usb-dac detection requires the DAC to be attached (powered on), else DietPi will not find the device index. Was the unit attached, powered on?

The SSD had to be larger than 31G or it refused to write. No problem I just used a bigger SSD and the install proceeded.

Yep, we generated the image on a 32GB EMMC, clonezilla does have options to write to a smaller target device, but i’ve bad experiences with it in the past.
32GB+ device required for now :slight_smile:

It didn’t work for me here on the Z83 - tried using the first method of manually editing the three files to sda, sdb etc - no luck.

Tried the new method with install menu but same story. I ctrl-c’d out of Clonezilla and did # blkid - the eMMc and the install USB drive showed but the target USB drive didn’t. # lsusb showed all drives. Why would that be?

Swapped the install and target drives round the three USB ports, but the install drive always grabbed sda.

Anyway decided to have a third attempt at installing to eMMC so after a backup - all went well. Have pretty much got the system running as it was before, Emby busy rescanning my media library.

Thanks Fourdee and your associates for all your work on this. I’ll tackle the XU4 next - easier prospect just shuffling SD cards.


Yes, this particular device uses USB power so once the PC is powered up it receives power and is on…

Also I noticed that when I try to install LMS it looks for the ARM version. Don’t know if that was the problem but it would not install via the Dietpi GUI. I had to uninstall LMS via the GUI and install it manually.

First install
sudo apt-get install libio-socket-ssl-perl

Then do a wget from the Nightly build page for my device [x86_64], from there a sudo dpkg -i … and everything was fine.

Hi John
Just for reference, I didn’t change anything in the files ie sda etc.

I just replaces the two files with those in the zip. I did have some problems with my bios recognizing the USB with the Dietpi/Conzilla at first, after a couple of attempts it recognized it.

Confirmed, we’ll investigate.