[Tutorial] PVE PiMox7 instalation on RPi 3B+ / 4B

|
Thanks to the DietPi Automation_Custom_Script.sh it is very easy to install a port of Proxmox Virtual Environment 7 - PiMox7.

The “installer” aka the Automation_Custom_Script.sh can be found here:
GitHub - TuxfeatMac/pimox7-installer: Installatin Scripts for PiMox7
https://github.com/TuxfeatMac/pimox7-installer/archive/refs/heads/main.zip <— all files in zip, direct download.

The installer cli output may be not that pretty, since it is ment to be run readless, this is okay… it works.

Als so the steps are very minimalistic:

  1. Flash the latest DietPi image from:
    —> https://dietpi.com/downloads/images/DietPi_RPi-ARMv8-Bullseye.7z .

  2. Replace orginal “dietpi.txt” and “config.txt” and add the “Automation_Custom_Script.sh” in /boot/ .

  3. Adjust the NETWORK and locale config in “dietpi.txt” to match your setup!

  4. Adjust options in “Automation_Custom_Script.sh” (optional)

  5. Insert the sd card into the RPi and power it up.

  6. Wait ~ 30 - 45 min, till reboot is done!

  7. Browse to https://<YOUR_SET_IP>:8006/

  8. Login with root and your set password.

  9. Enjoy ! =)


    Bonus: If automatic ISO and CT downloads are enabled, you are now ready set to create your first CT / VM!
    Maybe this little “how to” helps to keep you going: PiMox7 - RPi4 - arm64 CT & VM Basic Configuration - YouTube , if you have the “templates” skip to 1:46 .


    Notes
    more indetail, maybe found here:
    —> GitHub - pimox/pimox7: Proxmox V7 for Raspberry Pi
    —> GitHub - TuxfeatMac/pimox7-installer: Installatin Scripts for PiMox7
    —> [TUTORIAL] - How to run PVE 7 on a Raspberry Pi | Proxmox Support Forum

Greetings Tux_1024

2 Likes

thx for this nice guide.

Thank you for creating and sharing this dietpi.txt automation!

I have 4 RPI nodes added to my R720 and R620 cluster.

Any chance you’ve managed to get DietPi working on Pimox as a VM?

I’ve tried both LXC (unpriv) and a VM with the latest Debian cleanly installed.
Tried the DietPi converter Supported hardware - DietPi.com Docs but:

  • LXC stops when it cant use a loop device
  • VM cant boot after script ran (make-your-own-distro)
  • All other VMs (Ubuntu/Debian/Kali/Rocky etc clean installs) work just fine both ways

Awesome work everyone, thanks!

Welome to our community.

Today I was testing Pimox and to convert a Debian netinst system into DietPi. For me this was working without issues. I just setup a VM, run the installation using ARM64 Debian netinst iso. Once finished the VM could be converted into DietPi.

The question is, what system type you selected during DietPi installation? RPi or VM? Because you would need to select VM :slight_smile: