Having trouble connecting via SSH on Multiple Devices

Hello hello,

I am running DietPI on a RaspBerry Pi Zero W, and when I try to connect to it via SSH, it is either not connecting at all or extremely laggy. I have tried accessing on multiple devices but I still get the same issue.

I sometimes get this error:
ssh_dispatch_run_fatal: Connection to xxx.xxx.x.xx port 22: Connection timed out

Here is a screenshot if I am able to login:

I don’t believe its my internet connection, because I am able to access other installed software pretty quickly like File Browser and FreshRSS.

Is DietPi blocking SSH connections? How can I determine?

Sidenote: When I login to FreshRSS, I am getting “Access to database denied” message. I am not sure if this is related to this issue so I created a separate topic.

Use the terminal command: “ip a” to find out the name of the network interface, then use the command “sudo ethtool <interface>” to check the speed of the card in Mb/s.

sounds like some issues with the system in general. Any errors within the logs or kernel error messages?