Boots to black screen with Official Touchscreen Display

Hi!

I’ve been using DietPi with the official RPi 7’ touchscreen for months without issue – this weekend I decided to reflash and reinstall my setup for various reasons, but have hit a brick wall with DietPi and this display.

No matter what, any time I install additional software via dietpi-software, the RPi display will fail to show anything after the boot sequence finishes.

As an overview:

  • Download / flash / boot DietPi just fine
  • On first boot, the display works as expected, I can see the terminal on my display
  • I install no additional software or configure anything other than a desktop environment
  • I can successfully lauch into LXDE / Xfce and see this on the display
  • As soon as I install anything from dietpi-software and reboot, DietPi will run its boot sequence and the RPi Touch screen will fade white/black and appear in some form of illuminated ‘standby’ mode. The screen is on but nothing is displayed
  • Can still SSH fine and interact with DietPi
  • If I SSH in and set autostart to terminal (either auto or login), the same boot sequence to black happens
  • Plugging in a second external / standard HDMI monitor will result in DietPi working as expected, and the autostart to terminal/desktop works as expected

Additional info:

  • Running lsmod does not bring up raspberrypi_ts (I’m yet to check if it exists prior to installing software, will see if my sanity allows another reflashing!)
  • Touchscreen itself is working fine (visually and touch) up until the point I install any additional software
  • The hardware appears to be all wired up correctly (as evidence from the screen working on first boot)
  • No hardware/connection changes are occurring during the install
  • Reflashed DietPi to the SD Card several times, experiencing the same results
  • Flashed Raspberry Pi OS on the same SD Card and all works expected
  • DietPi and the screen had been working fine up until this weekend

I am very lost right now as to why the display would stop working like this, and how I can prevent this?

Did you use dtoverlay=vc4-kms-v3d or dtoverlay=vc4-fkms-v3d in the /boot/config.txt.

https://dietpi.com/forum/t/solved-enable-dietpi-boot-to-pimoroni-hyperpixel-display/6496/11

I can’t believe it, that was it!

The output of:

curl -sSL https://raw.githubusercontent.com/pimoroni/hyperpixel4/master/hyperpixel4-debug.sh | bash

Showed that dtoverlay=vc4-kms-v3d was active. Switching to dtoverlay=vc4-fkms-v3d appears to have resolved the issue. I gather that it maybe switched somehow during installation of software?

Thank you so much, I’ll be donating to DietPi now.

1 Like

you should be able to set vc4-fkms-v3d inside dietpi-config display options. Changing the option would require a reboot.

Switching those in dietpi-config worked. I can’t believe it was something so simple, but I’m relieved to see that it’s a known bug.

but not really one of DietPi :wink: