[SOLVED] Enable DietPI boot to Pimoroni HyperPixel display

/boot/dietpi/dietpi-config is a script, it replaces raspi-config. So don’t edit dietpi-config or you will maybe break the script.

You can run dietpi-config from CLI to set the graphic driver there.
This script than changes the settings in /boot/config.txt

I guess you are mixing thinks. /boot/dietpi/dietpi-config is not a configuration file. This is a shell script you can use to configure your entire system. It is similar to raspi-config.

The file you are looking for is /boot/config.txt. This is the standard RPi OS configuration file where you need to add your stuff. The file is available on DietPi as well, because DietPi is nothing else than a very basic RPI OS. Theoretically you are able to install raspi-config if you like.

EDIT: Dammit, I’m to slow :sunglasses:

Oh sorry I made some confusion, I edited and corrected the /boot/config.txt file and is the same as my old Raspbian but the display still doesn’t work.

I also installed the RPi.GPIO library for python and enabled the dtoverlay=vc4-fkms-v3d, but nothing.

Installed again the Pimorni script: https://github.com/pimoroni/hyperpixel4/tree/pi4 but nothing. The display driver doesn’t communicate with dietPI.

I don’t know what else try, suggestions? :frowning:

maybe you would need to activate I2C

dietpi-config > 4 : Advanced Options > I2C state

Unfortunately no. The display is still not working.

I’m curious to know how this guy https://dietpi.com/forum/t/dietpi-rpi-4-hyperpixel-4/3936/1 has done…

Can you post the output of

curl -sSL https://raw.githubusercontent.com/pimoroni/hyperpixel4/master/hyperpixel4-debug.sh | bash

And do you have a hyperpixel4.dtbo in /boot/overlays?

BTW are you using a RPi 4? There are a lot of issues on github with RPI 4s and black screens.

Edit:
It’s a bug since bullseye, see https://github.com/pimoroni/hyperpixel4/issues/155
Some solutions were this https://github.com/pimoroni/hyperpixel4/issues/155#issuecomment-966455983
or to use dtoverlay=vc4-kms-v3d instead of dtoverlay=vc4-fkms-v3d in the config.txt

Good luck.

Wow, thank you really a lot, at least I’m not stupid but is/was a bug! Although they’re talking about the touch version, this worked fine also for my non-touch!

Now I need only to rotate it, because the command doesn’t work, if you have another suggestions I would thank you again :smiley:

First start with

dtoverlay=vc4-kms-v3d

After replaced with

dtoverlay=vc4-fkms-v3d

the correct resolution is set

But rotate still doesn’t work

root@DietPi:~# hyperpixel4-rotate left
HyperPixel 4: Square - Display/Touch Rotation
This rotate utility only works with the Raspberry Pi OS desktop version or X-based alternatives.

Rotation requires hardware support on the Pi 4 or Pi 400
Ensure "dtoverlay=vc4-kms-v3d" is enabled in /boot/config.txt

My actual config.txt

display_rotate=3

dtoverlay=hyperpixel4
gpio=0-25=a2
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
dtoverlay=vc4-fkms-v3d

Hope this can help other people!

Found also the solution to rotate it!

dtoverlay=hyperpixel4
gpio=0-25=a2
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
display_rotate=3
dtoverlay=hyperpixel4-common
dtoverlay=hyperpixel4-0x14
dtoverlay=hyperpixel4-0x5d

Now I need only to change the font, I’m already using my old setup but here looks different

CHARMAP=”UTF-8"
CODESET=”guess”
FONTFACE=”guess”
FONTSIZE=”8x18"

Should be:

Anyone know what’s the differences?

Maybe is better if I open a new thread I think :thinking:

Try sudo dpkg-reconfigure console-setup
https://github.com/pi-hole/PADD/wiki/Sizes#the-sizes

Hello, I just signed up because i’m having the same issue. I have a pi zero 2w with a hyperpixel 4.0 square and i’d like to get dietpi to work with my screen. I already have an sd card ready and i can ssh into it. I’ve tried editing the config.txt like the example above but it doesn’t work for me. I installed rpi.gpio and enabled I2C. do I need to install anything else. I have the screen running on Raspberry pi os its really easy on there just add one line to the config.txt and thats all. I made this nice portable and would love to get dietpi working on it.

What exactly did you add in config.txt and what is your display showing? Nothing?

My screen is not showing anything.

dtoverlay=hyperpixel4sq
gpio=0-25a2
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
dtoverlay=vc4-fkms-v3d

With the update… I don’t remember which one, of DietPI, also my hyperpixel stopped working, I don’t remember what I did exactly but I installed something new (maybe new driver from Pimoroni? I relly don’t remember), anyway I also change the config.txt, now I’m using only:

dtoverlay=vc4-kms-dpi-hyperpixel4,rotate=270,disable-touch
dtoverlay=vc4-kms-v3d
dtoverlay=RPi-backlight

Try only it, and if it doesn’t work try to reinstall again the dtoveralys: GitHub - pimoroni/hyperpixel4: Driver for the Pimoroni HyperPixel 4.0" Touchscreen Display

the install process seems to be changed PSA: HyperPixel 4 (Square & Rectangular) on Raspberry Pi OS 64bit 2022-04-04 · Issue #177 · pimoroni/hyperpixel4 · GitHub

Thanks for your help. I got it to work sorry if but the image is unstable. I used your older config.

display_rotate=3

dtoverlay=hyperpixel4
gpio=0-25=a2
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
dtoverlay=vc4-fkms-v3d

But this is wrong, the image is pretty bad, you have to install the new driver/dtoverlay and then use the new config section.

I guess I’ll start over, i installed the legacy drivers.

are you using 64bit? If yes, legacy driver was the incorrect one. On current version, drivers should be build-in. This is a note from their install instructions

Pi 3B and Pi 4 users running the latest and greatest Raspberry Pi OS should forego our installer and use the instructions below.

And the info from thier web site

Raspberry Pi OS Bullseye includes major changes to how DPI display drivers work. If you’re using an image dated 04/04/2022 or later, it will come with Hyperpixel drivers baked in and you don’t need to run the installer. You can set up display and touch by adding a few lines to your boot/config.txt:
PSA: HyperPixel 4 (Square & Rectangular) on Raspberry Pi OS 2022-04-04

Yeah i think it is the 64bit version. I might give 32 bit a shot as well.

why would you do that?