AlloGUI Release Forum post #2 mistake on username

Required Information

  • DietPi version

  • Distro version: bullseye 0

  • Kernel version
    Linux DietPi 5.15.76-v8+ #1597 SMP PREEMPT Fri Nov 4 12:16:41 GMT 2022 aarch64 GNU/Linux

  • SBC model: RPi 4 Model B (aarch64)

  • Power supply used: 5V 1A XH-304 from Adafruit

  • SD card used: SanDisk Ultra

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?

Steps to reproduce

  1. Download AlloGUI, latest version, for RPi4b, write image onto SDCard, and boot in RPi2GB
  2. Access web gui to insure system is running
  3. Start Windows network mount from Linux Mint nemo: smb://dietpi.local/dietpi/
  4. Authenticate via username and password documented in forum post: DietPi - Web GUI Image - #2 by Fourdee FAQ section > Transfer music to the device (MPD+O!MPD) > Samba Server Details: username = root, password dietpi
  5. Repeat with smbclient:
smbclient --user=root%dietpi '\\\dietpi' 
tree connect failed: NT_STATUS_ACCESS_DENIED

Expected behaviour

Authenticate and see directories.

Actual behaviour

Failure to authenticate

Extra details

  • I installed Webmin, went to Servers > Samba > Samba Users and saw only: dietpi
  • Tried username dietpi, password dietpi and all worked. The post is out of date, please edit the username to correct! I do not know what version this changed, but please indicate older versions may use the root username. Thank you.

The post linked is more than 5 years old. Our current docs or located at File Servers Options - Docs. There user dietpi is correctly described as login username on Samba.