wget -O 41. Exit code: 1 installing emby

I get the folling error when trying to install emby on Raspberry pi 3b+

tPi-Software: wget -O 41.
Exit code: 1
DietPi version: v6.22.3 (MichaIng/master) | HW_MODEL:3 | HW_ARCH:2 | DISTRO:4
Image creator: DietPi Core Team
Pre-image: Raspbian Lite

Log file contents:
│ wget: missing URL
│ Usage: wget [OPTION]… [URL]…

│ Try `wget --help’ for more options.

│ Unable to continue, DietPi-Software will now terminate.

How to I get round this please, tried manual install guides elsewhere but they are all rubbish…

wget https://github.com/MediaBrowser/Emby.Releases/releases/download/
dpkg -i emby-server-deb_4.0.2.0_armhf.deb

solved my issue…

Many thanks for your report.

Damn their latest release has only be done for Windows currently: https://github.com/MediaBrowser/Emby.Releases/releases/tag/

For this reason our code does not find the URL for the Debian package on the API page we scan: https://api.github.com/repos/MediaBrowser/Emby.Releases/releases/latest

So we need to scan the full release API page: https://api.github.com/repos/MediaBrowser/Emby.Releases/releases
But this includes Beta version :thinking:.

Better is then we add a known fallback release for such cases.

Fixed for v6.23: https://github.com/MichaIng/DietPi/commit/ce890930d8239433f307b0bbe6219a84a718aedd
Changelog: https://github.com/MichaIng/DietPi/commit/27d364fc805e42db65a4f5afc7668bc2ae00460a

Many thanks again. It makes sense generally if we provide known fallback URLs in cases where we (attempt to) grab the latest release download URL automatically from some API page.

no worries, I ended up uninstalling that pos emby as its now pretty unusable. Going to try plex

Are there any specific issues with Emby or is it just performance wise?

crashes all the time. especially when clicking the dashboard icon in the web gui. Kodi also loses connection to emby all the time.

So far, plex hasn’t crashed once in the last few hours of setting up and playing… (emby was once like this…)
The Mrs. can get odd my back now… :wink: