Updating NodeRed breaks installation with node/glibc error

Creating a bug report/issue

Required Information

  • DietPi version | 8.18.2 / master / MichaIng
  • Distro version | buster 1
  • Kernel version | Linux 5.10.103-v71+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv71 GNU/Linux
  • Architecture | armhf
  • SBC model | RPi 4 Model B (armv71)

Additional Information (if applicable)

  • Software title | (NodeRed / 122)

  • Was the software title installed freshly or updated/migrated?
    tried to update

  • Can this issue be replicated on a fresh installation of DietPi?
    dietpi-software reinstall 122
    yes, following this discussion Updating node.js

  • Bug report ID | a4ae8cb8-e5ce-4341-bbe5-42d2aa06e0ca

Steps to reproduce

  1. Try to update NodeRed and node.js using
    dietpi-software reinstall 122

Expected behaviour

updated node-red and node.js

Actual behaviour

break with the error
`Error log: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version GLIBCXX_3.4.26 not found (required by node)

please let me know if there is anything else, I also tried manually updating using npm but had no luck.

If I’m not mistaken your operating system is too old and you would need to upgrade your system from Buster to Bullseye. DietPi - How to upgrade to "Bullseye" - DietPi blog

thats a good hint, i will try and report back