Update Portainer to 2.20

Dear all,

I am currently using portainer via the dietpi standard package manager together with docker 26. I just discovered that i am unable to enter the console of my docker containers via portainer. After some google research it turns out that this is a known issue and that an update to 2.20 should solve it. Unfortunately I was undable to figure out a way how to update portainer as the built-in packet manager does not show any updates.
Could anyone please help me :slight_smile:
Thanks a lot in advance and best regards

This version has not been released. You can check Portainer GitHub for version available GitHub - portainer/portainer: Making Docker and Kubernetes management easy.

Thanks for your fast reply. I am a little bit confused: According to docker hub, the version is already available: Docker

My confusion is mainly driven by the point that I am not away how to run an update of portainer: Do I have to update the docker container of portainer or is the update handled via the packet manager?

Thanks a lot!

Looks like the counter shows wrong version, 2.20 was released 3 weeks ago and 2.20.1 a week ago:

For an update you can just reinstall:

Thanks for the link, unfortunately it did not work. I am getting the following error message during the installation process:

docker: Error response from daemon: Conflict. The container name “/portainer” is already in use by container “4d81769d6de12451750600d17de7d3e9a2023ff51c97f7570cba01965da012”. You have to remove (or rename) that container to be able to reuse that name.

Should I rather follow the following instruction: Updating on Docker Standalone | 2.19 | Portainer Documentation

Thanks for your support!

Sometimes Portainer is restarting itself, therefore the image/container is in use.

Does manually stopping of the container is working?

docker stop portainer

Does this stop the container? Or will it be restarted again?

But this will not change anything to pull a new container. I don’t know why but on DockerHub, the portainer image having the latest tag is 4 month old. DockerHub latest image

It seems they have a new image but did not marked it as latest available. Therefore Portainer itself did not detect a new version, GitHub is not showing one and the image pulled is as well not the new one.

1 Like

Sorry for the delayed response but i unfortunately got sick :-/

So I just tried the following things:

  • Set the restart policy for the portainer container to “unless stopped” (it was set to “always” before)
  • Stopped the container using the command “docker stop portainer”
  • The run the update command again “dietpi-software reinstall 185”

Unfortunately the result was the same as above (… portainer already in use…)

After some frustration I tried the other instruction which I posted above (Updating to 2.19) und used the “2.20.1” tag instead of “latest” aaaaaannnnddd it worked :partying_face:

Thanks for your help guys!