Update DietPi from 7.5.2 to 7.9.3 keeps failing

First there was a mosqitto certificate error, removed mosquitto from dietpi, need it, now anyway we get cert errors and cannot upgrade.

Any ideas why we get this certificate error, as ca certificates already updated ?

Upgrade did not work in the past few months for any release greater than 7.5.2, thought time will solve this issue.

[ INFO ] DietPi-Update | APT update, please wait...
Get:1 https://download.docker.com/linux/raspbian stretch InRelease [31.1 kB]
Ign:2 https://mirror.netcologne.de/raspbian/raspbian stretch InRelease
Hit:3 https://repos.influxdata.com/debian stretch InRelease
Hit:4 https://archive.raspberrypi.org/debian stretch InRelease
Hit:5 https://packages.sury.org/php stretch InRelease
Err:6 https://mirror.netcologne.de/raspbian/raspbian stretch Release
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Reading package lists ...
E: The repository 'https://mirror.netcologne.de/raspbian/raspbian stretch Release' does no longer have a Release file

root@yyyyy:/etc/apt/sources.list.d# apt install ca-certificates
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ca-certificates is already the newest version (20200601~deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 78 not upgraded.

root@yyyyy:/etc/apt/sources.list.d# ls -ltr
total 16
-rw-r--r-- 1 root root 55 Sep  1  2018 influxdb.list
-rw-r--r-- 1 root root 75 Sep  6  2019 docker.list
-rw-r--r-- 1 root root 48 Feb  4  2021 dietpi-php.list
-rw-r--r-- 1 root root 60 Dec  4 18:28 raspi.list

root@yyyyy:/etc/apt/sources.list.d# cat raspi.list 
deb https://archive.raspberrypi.org/debian/ stretch main ui

Challenge is with the repository for mirror.netcologne.de. You would need to switch it from HTTPS to HTTP.

But at the end your oldold Debian Stretch version is the root for your issue. You should consider to upgrade at least to Debian Buster as will drop support for Stretch with next version.

Hello Joulinar,

correct changted to http, then update works and upgrade to buster performed

a) there is one line with stretch Hit:3 https://packages.sury.org/php stretch InRelease does this hurt ?
b) what is the recommended raspian version stretch or even bullseye

stretch 2019-04-08 -> buster 2021-05-07 -> bullseye 2021-10-30

thx a lot !!!

root@xxxx:/etc/apt# cat /etc/apt/sources.list

deb http://mirror.netcologne.de/raspbian/raspbian/ stretch main contrib non-free

 Phase: Checking for available DietPi update

[  OK  ] DietPi-Update | Checking network connectivity
[  OK  ] DietPi-Update | Checking DNS resolver
[  OK  ] Network time sync | Completed
[ INFO ] DietPi-Update | Getting latest version from: https://raw.githubusercontent.com/MichaIng/DietPi/master/.update/version
[  OK  ] DietPi-Update | Got valid latest version: 7.9.3
[  OK  ] DietPi-Update | No update required, your DietPi installation is already up to date:
[ INFO ] DietPi-Update | Current version : v7.9.3
[ INFO ] DietPi-Update | Latest version  : v7.9.3
[ INFO ] DietPi-Update | Checking for new available live patches
[ INFO ] DietPi-Update | APT update, please wait...
Get:1 https://download.docker.com/linux/raspbian stretch InRelease [31.1 kB]
Hit:2 https://repos.influxdata.com/debian stretch InRelease
Hit:3 https://packages.sury.org/php stretch InRelease
Hit:4 https://mirror.netcologne.de/raspbian/raspbian buster InRelease
Hit:5 https://archive.raspberrypi.org/debian buster InRelease
Fetched 31.1 kB in 4s (7374 B/s)
Reading package lists...
[  OK  ] DietPi-Update | APT update
[ INFO ] DietPi-Update | No APT upgrades were found, not creating file: /run/dietpi/.apt_updates

did you followed our guide to upgrade to Buster? I see still Debian Stretch repositories on your list


First complete the upgrade to Buster and ensure all working fine before continue to upgrade to Bullseye.

of course not, as I did not know, I performed.

1. apt-update worked with http
2. apt-upgrade worked in a screen command (hanged without)
3. changed /etc/apt/sources.list   to buster
4. dietpi-update works
5. apt dist-upgrade -y  (also in screen as hanged, and waited a night...)
6. sudo apt autoremove -y 
7. sudo apt autoclean
8. sudo reboot

pls follow our guide from the beginning to migrate fully to Buster