Unable to enable WiFi on Raspberry 4

Creating a bug report/issue

Required Information

  • DietPi version | cat /boot/dietpi/.version
    G_LIVE_PATCH_STATUS[0]=‘not applicable’

  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
    bullseye 0

  • Kernel version | uname -a
    Linux DietPi 5.15.76-v8+ #1597 SMP PREEMPT Fri Nov 4 12:16:41 GMT 2022 aarch64 GNU/Linux

  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
    RPi 4 Model B (aarch64)

  • Power supply used | (EG: 5V 1A RAVpower)
    Raspberry stock 3A USB PSU

  • SD card used | (EG: SanDisk ultra)
    HDD: ST500LM012 HN-M500MBB

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

enable WiFi in dietpi-config

Expected behaviour

WiFi Module should be enabled

Actual behaviour

WiFi module is not found, even after reboot

Extra details


I’m trying to enable the AP mode of my raspberry additional to the existing and mandatory ethernet connection. However, dietpi-config states, that no WiFi Module can be found, even after a reboot:

Could you please advice, how to enable the WiFi module?

Best regards,

hiii @Haarwurm ,

welcome to the Dietpi family, :call_me_hand:

Can be seen here: No Wi-Fi hardware found? - Troubleshooting - DietPi Community Forum
or else :
[RPi 3 Model B] fresh install of bullseye: Wifi (adapter) not found - Troubleshooting - DietPi Community Forum
Wi-Fi RPi 4 - No supported WI-FI hardware was found · Issue #4770 · MichaIng/DietPi · GitHub.


Hi @TahitianVibes , thank you for your answer.

I already checked some forum postings, unfortunately no one solved my problem:
No Wi-Fi hardware found? - Troubleshooting - DietPi Community Forum - h**ps://dietpi.com/forum/t/no-wi-fi-hardware-found/11227/6 → reboot solved this issue, I’ve rebooted my raspberry already with no effect.

h**ps://dietpi.com/forum/t/rpi-3-model-b-fresh-install-of-bullseye-wifi-adapter-not-found/5880 → switching onboard wifi on solved the problem. The wifi of my raspberry is already enabled as you might see on the screenshot, of cource I’ve rebooted the raspberry, several times now.

Wi-Fi RPi 4 - No supported WI-FI hardware was found · Issue #4770 · MichaIng/DietPi · GitHub - h**ps://github.com/MichaIng/DietPi/issues/4770. - enabling bluetooth was the last proposal was about enabling bluetooth. I’ve enabled it now, rebooted the pi, no effect.

Best regards,

WiFi is working now. I had to install the WiFi firmware, since it was missing (or at least this is my understanding of the issue):

sebastian@DietPi:~$ apt list *raspberrypi*
Listing... Done
libraspberrypi-bin-dbgsym/stable 1:2+git20220324~090146+c4fd1b8-1 arm64
libraspberrypi-bin/stable,now 1:2+git20220324~090146+c4fd1b8-1 arm64 [installed]
libraspberrypi-dev/stable 1:2+git20220324~090146+c4fd1b8-1 arm64
libraspberrypi-doc/stable 1:2+git20220324~090146+c4fd1b8-1 all
libraspberrypi0-dbgsym/stable 1:2+git20220324~090146+c4fd1b8-1 arm64
libraspberrypi0/stable,now 1:2+git20220324~090146+c4fd1b8-1 arm64 [installed]
raspberrypi-archive-keyring/stable,now 2021.1.1+rpt1 all [installed]
raspberrypi-bootloader/stable,now 1:1.20221104-1 arm64 [installed]
raspberrypi-kernel-headers/stable 1:1.20221104-1 arm64
raspberrypi-kernel/stable,now 1:1.20221104-1 arm64 [installed]
raspberrypi-net-mods/stable 1.3.4 all
raspberrypi-sys-mods/now 2:20220915-dietpi2 all [installed,local]
raspberrypi-ui-mods/stable 1.20221130 arm64
sebastian@DietPi:~$ journalctl -b | grep brcmfmac
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal' can see all messages.
      Pass -q to turn off this notice.
No journal files were opened due to insufficient permissions.
sebastian@DietPi:~$ sudo journalctl -b | grep brcmfmac
Dec 02 12:40:32 DietPi kernel: brcmfmac: F1 signature read @0x18000000=0x15264345
Dec 02 12:40:32 DietPi kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
Dec 02 12:40:32 DietPi kernel: usbcore: registered new interface driver brcmfmac
Dec 02 12:40:32 DietPi kernel: brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.bin failed with error -2
Dec 02 12:40:32 DietPi kernel: brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.bin failed with error -2
Dec 02 12:40:33 DietPi kernel: brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
sebastian@DietPi:~$ apt search bcm4345
Sorting... Done
Full Text Search... Done
firmware-brcm80211/stable 1:20221012-1~bpo11+1+rpt1 all
  Binary firmware for Broadcom/Cypress 802.11 wireless cards
sebastian@DietPi:~$ sudo apt-get install firmware-brcm80211
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 5859 kB of archives.
After this operation, 20.5 MB of additional disk space will be used.
Get:1 https://archive.raspberrypi.org/debian bullseye/main arm64 firmware-brcm80211 all 1:20221012-1~bpo11+1+rpt1 [5859 kB]
Fetched 5859 kB in 1s (8852 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package firmware-brcm80211.
(Reading database ... 47549 files and directories currently installed.)
Preparing to unpack .../firmware-brcm80211_1%3a20221012-1~bpo11+1+rpt1_all.deb ...
Unpacking firmware-brcm80211 (1:20221012-1~bpo11+1+rpt1) ...
Setting up firmware-brcm80211 (1:20221012-1~bpo11+1+rpt1) ...
sebastian@DietPi:~$ sudo reboot
sebastian@DietPi:~$ sudo ifconfig | grep wlan
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500

was that a new installation?

At least on my demo system, the package is pre-installed already

root@DietPi4:~# dpkg -l firmware-brcm80211
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name               Version                   Architecture Description
ii  firmware-brcm80211 1:20221012-1~bpo11+1+rpt1 all          Binary firmware for Broadcom/Cypress 802.11 wireless cards

The installation itself is a few months old, I only need wifi now, therefore maybe the issue was already there, but unnoticed.

Hmm the package should be there all the time. I will do a test with latest image available on our web site.

Save your time. In august, I’ve deleted the package with the intention to delete unneeded software. As already told, in general I don’t need wifi:

root@DietPi:~# sudo apt-get remove --purge

What I gain as insight from this experience: Maybe DietPi-config should check on the wifi enabling occasion, if “the/any?” wifi driver is installed?

Best regards and thank you for your excellent work,

1 Like

@MichaIng do we already check for the available if the firmware package?

No we don’t. Also it wouldn’t be trivial and failsafe to derive the correct firmware package based on WiFi chip.

  • It already starts with how to get WiFi chip info: lsusb works for USB adapters only, of course, in other cases it’s lspci (not preinstalled on DietPi), and I’m not entirely sure how to derive on RPi, to be true (while I know onboard a Broadcom chip => firmware-brcm80211).
  • Next is, if there are multiple WiFi adapters, how to know which one is used for which network interface.
  • And finally on different SBCs, different packages ship the needed firmware: On Armbian it’s the single armbian-firmware package, on Quartz64 we ship those for onboard WiFi with our own firmware-*quartz* packages.

This complexity is also the reason we do not offer to purge WiFi firmware packages when WiFi is disabled, but only the userland tools.

Would be great if we were able to check for this reliably, since those firmware packages are large in size, so great cleanup potential, but AFAIK we are not.

1 Like