[RPi 3 Model B] fresh install of bullseye: Wifi (adapter) not found

I just did a fresh install.
RPi 3 Model B
Image: ARMv8 64-bit from https://dietpi.com/downloads/images/DietPi_RPi-ARMv8-Bullseye.7z

I did the minimal installation of DietPi by connected ethernet, which updated itself to DietPi v7.7.3.
After that I wanted to configure Wi-fi, but there is no wifi adapter found. Reboot didn’t work.

I did this twice, but it didn’t work.

So I tried this with the official raspios image from https://downloads.raspberrypi.org/raspios_lite_armhf/images/raspios_lite_armhf-2021-05-28/2021-05-07-raspios-buster-armhf-lite.zip . Release date: May 7th 2021
With this image, the wifi adapter is found and I can connect to my wi-fi.

May I ask you for help with debugging? Which information can I provide?

Thank you!

Pls switch OnBoard WiFi to on and reboot your system.

Joulinar : Thank you, the switch of OnBoard Wifi to on solved my problem.
I’m sorry to overlooked that and thankful your help! Thank you!

Maybe a suggestion for fresh installs: Enable OnBoard Wifi by default?

it is disabled by default. But it can be activated before first boot. Just have a look to our online docs https://dietpi.com/docs/install/

At the end of section 2 you will find a blue box called Click here if you want to use a WiFi connection

Sorry and thank you again! :smiley: