Transmission-daemon.service wont start

Creating a bug report/issue

Required Information

  • DietPi version | 8.14

  • Distro version | bullseye 0

  • Kernel version | Linux DietPi 5.15.84-v8+ #1613 SMP PREEMPT Thu Jan 5 12:03:08 GMT 2023 aarch64 GNU/Linux

  • SBC model | RPi4 Model B

  • Power supply used | 5V 1A

  • SD card used | (EG: SanDisk ultra)

Additional Information (if applicable)

  • Software title | Transmission
  • Was the software title installed freshly or updated/migrated? Freshly installed
  • Can this issue be replicated on a fresh installation of DietPi? I dont know
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

  1. I belive I upgraded some days ago with no other problems, but since I rebooted the pi, the service
    transmission-daemon wont start.

Expected behaviour

  • Service runing as before

Actual behaviour

  • sytemctl status give me a timeout error, If I try to restart the service it causes a loop, with no results, I can see it under HTOP but it wont stop.
  • I tried killing transmission-daemon and starting it with:
    sudo -u debian-transmission /usr/bin/transmission -f --log-debug whitout succes, it freezes, even cant use Ctrl+c to stop it

Extra details

Maybe something got corrupted. Take a backup of your configuration and reinstall

cp /etc/transmission-daemon/settings.json /root/settings.json
dietpi-software uninstall 44
dietpi-software install 44
dietpi-services stop transmission-daemon
cp /root/settings.json /etc/transmission-daemon/settings.json
dietpi-services restart transmission-daemon
chown debian-transmission.debian-transmission /etc/transmission-daemon/settings.json
1 Like

Thanks, for the quick response.
Sorry for the silly question, i have torrents in multiple paths, in the settings json I can see my default download folder specificied. If I keep only the json (and source material ofc) Would remember transmission all the torrents?

Thanks again!!

My guess is that you’ll have to add the torrents. Unless there is some cache file with the loaded torrents you can also transfer.

1 Like

Thanks so much, I saved the torrents files, default path is:
/var/lib/transmission-daemon/.config/transmission-daemon/torrents

But I cant uninstall it, I have got an error deleting the user ‘debian-transmission’. Tried using sudo too with the error handler whitout succes.

Is it safe to uninstall ‘manually’? I mean
apt purge transsmision ; sudo userdel debian-transmission

I prefer using the script btw, love those little tools. They are one of the reasons I install dietpi for anyone asking…

Ok, I am an idiot, didnt saw that two procces was holding the user from deleting. Used another ssh to kill both proccess it with sudo kill -9 $PID and retried the script, which worked instantly.
Installed again and now I am restoring the backed up torrent files.
Everything looks like is works fine.

Thanks again!!

1 Like

After almost a week of working whitout problems, I have the same error again, I can restore like the previous time, but I would love to find the root problem and reverse it once for all.
What can I do to find more info about what is causing this?

I think one of the drivers is failing (running checks atm, i ll edit to add this info) but I dont belive that this is the problem, at those drives there are only the data of the torrents.

Any help would be appreciated!!

You can have a look into the logs
journalctl -u transmission-daemon

I checked it, but it doesnt help me:

Feb 28 14:10:52 DietPi systemd[1]: Starting Transmission BitTorrent Daemon...
Feb 28 14:12:22 DietPi systemd[1]: transmission-daemon.service: start operation timed out. Terminating.
Feb 28 14:13:52 DietPi systemd[1]: transmission-daemon.service: State 'stop-sigterm' timed out. Killing.
Feb 28 14:13:52 DietPi systemd[1]: transmission-daemon.service: Killing process 1279 (transmission-da) with signal SIGKILL.
Feb 28 14:13:52 DietPi systemd[1]: transmission-daemon.service: Killing process 1349 (transmission-da) with signal SIGKILL.
Feb 28 14:13:52 DietPi systemd[1]: transmission-daemon.service: Main process exited, code=killed, status=9/KILL
Feb 28 14:13:52 DietPi systemd[1]: transmission-daemon.service: Failed with result 'timeout'.
Feb 28 14:13:52 DietPi systemd[1]: Failed to start Transmission BitTorrent Daemon.

Maybe you can see further than me, I am a total noob looking at logs

processes getting killed from the system. can you check kernel error logs

dmesg -l 0,1,2,3

Thanks a lot @Jappe and @Joulinar , I checked dmesg (didnt used it, will read manpage for further checks, thanks a lot)
The output is these lines reapeated times:

[  227.078151] usb usb2-port1: unable to enumerate USB device
[  231.157574] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?

Could be the faulting device the problem? Usually this didnt break transmission, only torrents on those devices…

I dont know why, but using same ports on the pi, but in opposite order, it works… Never saw transmission stop because drives failed, nice ‘alert’, buying some new ssd to replace the old hdd.
Thanks again, looks like it is working whitout problems.

1 Like

how do you power the drives? Directly from RPI device or using some external PSU? from our side we always recommend to use external power supply.

1 Like

I have a external dock with his own supply.
I dont know what was the problem, but after the last change is running smothly.