Drive Manager Not Working

  • DietPi version v8.15.2
  • RPi 4 Model B (aarch64)

DietPi was working flawlessly for a few years on Raspberry Pi 4 and have had no issues. It’s on the lastest version and I haven’t installed anything new or out of the ordinary, just the newest updates whenever I can via SSH - the newest update was installed about a week or so ago. However, yesterday things stopped working… I can’t access the network share via Windows or Mac, Sonarr web interface, Radarr web interface, Transmission web interface.

I first noticed that Plex was not working. I can see the media but it says “Unavailable”. I tried rebooting, restarting services but to no avail. I can still access Jacket web interface, and I can still log into DietPi via Terminal ssh root@ so I was able to get some screenshots. It appears that all services are running except for Transmission for some reason…

Any help with getting this back up and running is greatly appreciated!

There seems to sessions hanging background not being closed correctly. After reboot, are you able to get into drive manager? Or do you still have the message about a concurrent session running?

Same message after reboot

this usually can’t be the case as all open sessions should be gone. Are you sure your system rebooted at all? Did you tried to power cycle?

Yes, I have tried power cycling and I think my issue has something to do with Transmission

Similar to this thread but I can’t seem to get it resolved

As you reported multiple issues, let’s sort them one by one.

What about drive manager? Are you able to open it now?

Drive Manager shows the following. I try to open it the first time and nothing happens so I have to cancel. Then I try again and I get the following “concurrent execution” message.

this is the launcher and not drive manager shown on the picture.

this is logic and expected as you cancel the first session leaving some parts behind. How long do you wait before cancelling the session? For me it looks like you have an external mount point that is not reachable, leading drive manager to hang. Usually there should be a timeout after 90 sec. Can you share your /etc/fstab file.

cat /etc/fstab
lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid

Oh OK, thank you for the feedback… here is the result. Does it help to troubleshoot the issue?

there are basically 2 shares/drives that might cause issues.

  1. is a SAMBA network share. The IP address seems to be strange as ist has 192.168.127. A regular IP should have 4 octet insted of 3.

  2. next issue might be the missing 8TB USB NTFS drive. It is configured on your system but not attached/available.

You would need to check both entries in your /etc/fstab and correct or remove them from configuration

BTW: one hint, try to avoid doing screen prints. You should be able to copy all information from SSH terminal directly.

Yes you are right, my network share goes by rather than http://192.168.127
Would I be able to resolve that with /etc/fstab?

When I type /etc/fstab I get “permission denied”

root@DietPi:~# /etc/fstab
-bash: /etc/fstab: Permission denied
root@DietPi:~# sudo /etc/fstab
sudo: /etc/fstab: command not found

you need to specify an editor like

nano /etc/fstab

As well check the USB drive.

Well, we are getting somewhere. I checked the USB drive and oddly enough, it was powered off. My mistake! Now I can access the drive again. However, when I try to access my Plex media it still says that the media is unavailable. Linked below are screenshots within Plex:

I have tried power cycling everything but to no avail. I also believe that 192.168.127 is actually correct, as this is the “local IP” for the Raspberry Pi.

# You can use "dietpi-drive_manager" to setup mounts.
# NB: It overwrites and re-creates physical drive mount entries on use.
//192.168.127/4tb /mnt/smbshield cifs cred=/var/lib/dietpi/dietpi-drive_manager/mnt-smbshield.cred,iocharset=utf8,uid=dietpi,gid=dietpi,file_mode=0770,dir_mode=0770,vers=3.1.1,nofail,noauto,x-systemd.automount

tmpfs /tmp tmpfs size=1024M,noatime,lazytime,nodev,nosuid,mode=1777
tmpfs /var/log tmpfs size=50M,noatime,lazytime,nodev,nosuid,mode=1777

# MISC: ecryptfs, vboxsf, glusterfs, bind, Btrfs subvolume mounts

/var/swap none swap sw

PARTUUID=9bcc366d-02 / ext4 noatime,lazytime,rw 0 1
PARTUUID=9bcc366d-01 /boot vfat noatime,lazytime,rw 0 2
UUID=F65C2DF55C2DB173 /mnt/8tb ntfs noatime,lazytime,rw,permissions,big_writes,nofail,noauto,x-systemd.automount

Also, just to add:

dosn’t seems correct. An IP address has 4 octets and not only 3. And what do you mean by “local IP” for the Raspberry Pi?? The share is a Samba server running somewhere in your network and you would need to specify the correct IP address for these Samba server.

I will adjust this to // using nano /etc/fstab and report back

Unfortunately it’s still not working, even after this IP adjustment was made to /etc/fstab. I rebooted and still cannot see the drive within Plex, however I can access the shared drive normally via macOS.

I am not sure if it’s a permission issue, from what I can gather permissions are set within DietPi Drive Manager but when I try to launch DietPi-Drive_Manager I get the following message:

 [ INFO ] DietPi-Drive_Manager | Concurrent execution of DietPi-Drive_Manager detected, retrying... (1/5)

[ INFO ] DietPi-Drive_Manager | Concurrent execution of DietPi-Drive_Manager detected, retrying... (2/5)

[ INFO ] DietPi-Drive_Manager | Concurrent execution of DietPi-Drive_Manager detected, retrying... (3/5)

[ INFO ] DietPi-Drive_Manager | Concurrent execution of DietPi-Drive_Manager detected, retrying... (4/5)

Did you cancelled drive manager? Because there is still a session within the background. Let’s do following, remove the Samba share entry completely from /etc/fstab. Save configuration and verify entry has been removed. Reboot your system afterwards. Once back online, open drive manager. Does this works? Don’t cancel the session if it is hanging again. Just wait on the 90 second time out.

Thank you, doing that allows me to view the Drive Manager now finally :slight_smile:
There is no hanging, it opens up right away.

So perhaps this line of text is incorrect? Should I add it back directly to /etc/fstab, or do so via Drive Manager?

// /mnt/smbshield cifs cred=/var/lib/dietpi/dietpi-drive_manager/mnt-smbshield.cred,iocharset=utf8,uid=dietpi,gid=dietpi,file_mode=0770,dir_mode=0770,vers=3.1.1,nofail,noauto,x-systemd.automount

When I try to create a new Samba share it says the following: