Temporary failure resolving 'mirror.yandex.ru'

Diet Pi is working fine. Trying to do and update.

Error on update is: “Temporary failure resolving ‘mirror.yandex.ru’”
I live in Ukraine and ‘yandex.ru’ is blocked so thinking I need to remove this as a mirror.

How can I get around this and update?

can you share the whole error message pls. Btw: was there a reason to ignore our trouble shooting template? There is some reason behing :wink:

Sorry, I live in the city of Kherson and the shelling started again and the wife was yelling and I just wanted to ask the question before the power died again.

Anyway, sorry. Should of waited and filed the ticket properly. . I just am struggling with patients at the moment. Again, I am sorry.
So… Lets try this


  • Date | Wed Apr 5 16:33:37 BST 2023
  • DietPi version | v7.2.3 (MichaIng/master)
  • Image creator | DietPi Core Team
  • Pre-image | Armbian
  • Hardware | ROCK64 (aarch64) (ID=43)
  • Kernel version | Linux DietPi 5.10.35-rockchip64 #21.05.1 SMP PREEMPT Fri May 7 13:53:11 UTC 2021 aarch64 GNU/Linux
  • Distro | buster (ID=5)
  • Command | apt-get -qq upgrade
  • Exit code | 100
  • Software title | DietPi-Update

Steps to reproduce:

  1. Live in Ukraine
  2. Run the DietPi update program

Expected behaviour:

Update should run

Actual behaviour:

fails with error of not finding russian mirror.

Extra details:

Ukraine has blocked all Russian web sites. I also tried maybe run apt-get update or try with --fix-missing but the same issue. Did research and found that by removing the russian mirror from some file you can bypass the using the russian mirror web site. Just do not know where that file is.

Additional logs:

E: Failed to fetch http://apt.armbian.com/pool/main/a/armbian-firmware/armbian-firmware_23.02.2_all.deb  Temporary failure resolving 'mirror.yandex.ru'
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Again, sorry. :wink:

Hang on in there, mate!

Go to dietpi-config then Network Options-MIsc and select another APT mirror from the first option, or you can input your custom.

I already did, sorry should of mentioned that.

And which one did you use?

One in the US and UK. Going to try again now.

It is the global apt package server for Armbian that has a pool of server behind. Something we don’t manage which server is selected. However, we could specify a dedicated mirror.

Let’s check where it is configured exactly as I’m not 100% sure on exact file name :smiley:

for i in /etc/apt/sources.list{,.d/*.list}; do echo "$i:"; cat "$i"; done
1 Like

There is a list which also includes Ukranian servers.

1 Like

But these are Debian. We need Armbian one :wink:

1 Like


ok one hint, try to avoid screen prints. Way better to copy /past thinks directly from SSH terminal :wink:

Try to adjust following /etc/apt/sources.list.d/armbian.list and adjust the package source from https://apt.armbian.com/ into http://mirrors.xtom.de/armbian/

Save the file and run apt update

I tried the copy - paste, it did not like all the links - complained about new person stuff… :wink:

you can place your feedback from SSH terminal into code fences like this

type or paste code here
Hit:10 http://ftp.us.debian.org/debian buster-backports InRelease
Fetched 499 kB in 4s (116 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
290 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch http://mirrors/xtom/de/armbian/dists/buster/InRelease  Could not resolve 'mirrors'
W: Some index files failed to download. They have been ignored, or old ones used instead.

Trying an diet pi update again… something is happening. :wink:

│  - Command: apt-get -y update
│  - Exit code: 255
│  - DietPi version: v8.15.2 (MichaIng/master) | HW_MODEL: 43 | HW_ARCH: 3 |
│  - Image creator: DietPi Core Team
│  - Pre-image: Armbian
│  - Error log:
│ Err:1 http://mirrors/xtom/de/armbian buster InRelease
│   Could not resolve 'mirrors'
│ Hit:2 https://deb.debian.org/debian-security buster/updates InRelease
│ Hit:3 https://download.mono-project.com/repo/debian buster InRelease
│ Hit:4 https://packages.microsoft.com/debian/10/prod buster InRelease
│ Hit:5 http://ftp.us.debian.org/debian buster InRelease
│ Hit:6 https://packages.microsoft.com/repos/microsoft-debian-jessie-prod
│    Retry          : Re-run the last command that failed                 ↑
│    DietPi-Config  : Edit network, APT/NTP mirror settings etc        

So looks like we made it to v8.15.2!
Thanks all.

Something got wrong during configuration on your side

This is your config


But it should be


Some dots . changed into slash /. Pls review source file again.

1 Like

I see you configured backports, this will go to upgrade quite some packages (290) now. Are you sure this is intentional? Better to upgrade to Bullseye instead DietPi - How to upgrade to "Bullseye" - DietPi blog

1 Like

Fixed the typo on the mirror and we are good there now. Mirror is found.

I am going to start a fresh install to the new Bullseye image. I am sure I will still need to change the mirror though. Thanks for all the help.