Sonarr V3 install - permissions

Hey there,

I followed from a different thread the instructions to update to V3 on my RPI4 here
I followed the buster 10 instructions and after running the

sudo apt install sonarr

I get prompted with a user and group. I believe when I tried it the first time I had sonarr as the user and dietpi as the group? It seemed to of borked the install and I couldn’t get it back without purging it and reinstalling through dietpi software. What is the correct user and group I should follow if doing an upgrade this way? Thank you.


I did a Sonarr test installation and updated to v3 following Buster instructions. During update, I used user sonarr & group dietpi and the installation finished without issues. Sonarr updated to v3 and is reachable. So it should work this way.


I’ll try again now. I have a feeling perhaps I may have left it at default sonarr user and sonarr group.

Can I re run the sudo apt install sonarr and get the user and group to appear again? I was trying to configure it on my mobile and the UI was cut off and I couldn’t input the user and group correctly. :frowning:

Fixed it, sudo dpkg-reconfigure sonarr and it fixed itself up.

don’t think this is gonna work. I guess this is a feature available during initial migration from v2 to v3 only

I tried all of the above but no luck. If I reboot and open Sonarr it is still showing V2. I also got an error after running V3 instructions;

sonarr.service is a disabled or a static unit, not starting it.

I think I give up for now