[SOLVED] Enable DietPI boot to Pimoroni HyperPixel display

Hi,
first time I install dietPI and is very nice, but I need the option to auto-boot to my external Pimoroni display attached via GPIO.

Using raspby-config the option it’s “auto-login to tty” or something similar, what’s the same option to show the output to my display in dietPI?

Thanks a lot!

PS: I need it because I’m using my raspberry with pihole and PADD to display the stats, here’s my config:

have a look to dietpi-autostart. Select option 7 if you like to login to CLI

Uhm, I’ve already done it.

I suspect this is due to the driver, but I also installed it, so I don’t understand why the display doesn’t show anything. Any idea to solve this trouble?

Make sure the PADD script is also executed at boot. And can you config somewhere in PADD which output is used?

BTW dietpi-cloudshell also allows to show system stats (including some pihole stats) on an external display.

Yes’ it’s enabled but the display simply does show nothing, blank.

I found this interesting thread here on the forum: https://dietpi.com/forum/t/dietpi-rpi-4-hyperpixel-4/3936/1 so I think the problem is the install script of the drivers that uses the /boot/config but dietpi uses /boot/dietpi/dietpi-config file. I tried to edit it but it’s weird, I should insert those lines to the boot (as my old raspbian installation)

dtoverlay=vc4-fkms-v3d
max_framebuffers=2
dtoverlay=hyperpixel4,touchscreen-inverted-3,touchscreen-inverted-3
display_rotate=3
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6

How can I pass this to /boot/config?

Thanks

/boot/dietpi/dietpi-config is a script, it replaces raspi-config. So don’t edit dietpi-config or you will maybe break the script.

You can run dietpi-config from CLI to set the graphic driver there.
This script than changes the settings in /boot/config.txt

I guess you are mixing thinks. /boot/dietpi/dietpi-config is not a configuration file. This is a shell script you can use to configure your entire system. It is similar to raspi-config.

The file you are looking for is /boot/config.txt. This is the standard RPi OS configuration file where you need to add your stuff. The file is available on DietPi as well, because DietPi is nothing else than a very basic RPI OS. Theoretically you are able to install raspi-config if you like.

EDIT: Dammit, I’m to slow :sunglasses:

Oh sorry I made some confusion, I edited and corrected the /boot/config.txt file and is the same as my old Raspbian but the display still doesn’t work.

I also installed the RPi.GPIO library for python and enabled the dtoverlay=vc4-fkms-v3d, but nothing.

Installed again the Pimorni script: https://github.com/pimoroni/hyperpixel4/tree/pi4 but nothing. The display driver doesn’t communicate with dietPI.

I don’t know what else try, suggestions? :frowning:

maybe you would need to activate I2C

dietpi-config > 4 : Advanced Options > I2C state

Unfortunately no. The display is still not working.

I’m curious to know how this guy https://dietpi.com/forum/t/dietpi-rpi-4-hyperpixel-4/3936/1 has done…

Can you post the output of

curl -sSL https://raw.githubusercontent.com/pimoroni/hyperpixel4/master/hyperpixel4-debug.sh | bash

And do you have a hyperpixel4.dtbo in /boot/overlays?

BTW are you using a RPi 4? There are a lot of issues on github with RPI 4s and black screens.

Edit:
It’s a bug since bullseye, see https://github.com/pimoroni/hyperpixel4/issues/155
Some solutions were this https://github.com/pimoroni/hyperpixel4/issues/155#issuecomment-966455983
or to use dtoverlay=vc4-kms-v3d instead of dtoverlay=vc4-fkms-v3d in the config.txt

Good luck.

Wow, thank you really a lot, at least I’m not stupid but is/was a bug! Although they’re talking about the touch version, this worked fine also for my non-touch!

Now I need only to rotate it, because the command doesn’t work, if you have another suggestions I would thank you again :smiley:

First start with

dtoverlay=vc4-kms-v3d

After replaced with

dtoverlay=vc4-fkms-v3d

the correct resolution is set

But rotate still doesn’t work

root@DietPi:~# hyperpixel4-rotate left
HyperPixel 4: Square - Display/Touch Rotation
This rotate utility only works with the Raspberry Pi OS desktop version or X-based alternatives.

Rotation requires hardware support on the Pi 4 or Pi 400
Ensure "dtoverlay=vc4-kms-v3d" is enabled in /boot/config.txt

My actual config.txt

display_rotate=3

dtoverlay=hyperpixel4
gpio=0-25=a2
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
dtoverlay=vc4-fkms-v3d

Hope this can help other people!

Found also the solution to rotate it!

dtoverlay=hyperpixel4
gpio=0-25=a2
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
display_rotate=3
dtoverlay=hyperpixel4-common
dtoverlay=hyperpixel4-0x14
dtoverlay=hyperpixel4-0x5d

Now I need only to change the font, I’m already using my old setup but here looks different

CHARMAP=”UTF-8"
CODESET=”guess”
FONTFACE=”guess”
FONTSIZE=”8x18"

Should be:

Anyone know what’s the differences?

Maybe is better if I open a new thread I think :thinking:

Try sudo dpkg-reconfigure console-setup
https://github.com/pi-hole/PADD/wiki/Sizes#the-sizes