[Solved] Dietpi on OdroidC4 no HDMI audio output listed

Creating a bug report/issue

Required Information

  • DietPi version | v8.9.2
  • Distro version | Dietpi OdroidC4 ARMv8 Bullseye
  • Kernel version | 5.10.147-meson64
  • SBC model | Odroid C4 (in terminal states: Odroid C4/HC4 (aarch64) )
  • Power supply used | DC 12v 2.0A
  • SD card used | SanDisk ultra 64gb

Additional Information

  • All software freshly installed.
  • Can this issue be replicated on a fresh installation of DietPi?
    I assume so.

Steps to reproduce

  1. …Download and flash DietPi_OdroidC4-ARMv8-Bullseye.7z (from Dietpi.com)
  2. …Install XDFE desktop on first boot

Expected behaviour

Dietpi-config /audio settings, should list HDMI output as default.

Actual behaviour

Dietpi-config /audio settings/Soundcard shows:
Usb-dac: USB Audio DAC (any)
hw: 0,0 : SM10DROIDC4
hw: 0,1 : SM10DROIDC4
hw: 0,2 : SM10DROIDC4

Extra details

Using Ubuntu 20.04 and 22.04 HDMI audio works fine.
Using Core Elec HMDi audio works fine.
HDMI cable plugged into a TCL smart TV. No problems with display. (1360x768@60Hz)
Tried all listed desktop environments - same problem

Relative newbie with Linux, please help with step by step instructions.

Update:
In terminal: speaker-test -c2. Plays Audio!

Update: installed pulse audio. I have sound now!

Hi, I have the same hardware and latest dietpi version, and I get the same output, no hdmi audio.

When playing speaker test, it gives this error:

dietpi@DietPi:~$ speaker-test -c2

speaker-test 1.2.4

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 4 to 262144
Period size range from 2 to 131072
Using max buffer size 262144
Periods = 4
Unable to set hw params for playback: Invalid argument
Setting of hwparams failed: Invalid argument

Which tests can I run, to see if everything is fine.

Thank you!

P:D: I can open another thread if it is better.

you have installed as well pulse audio like to OP? At least this seems to have fixed it for him.

Sorry for the late answer,
Yes I’ve tried installing pulseaudio, and no sound…
Is there anything I can do to restore audio settings or packages to it’s defaults, and start from zero?