[Solved] Dietpi hardware volume on i-sabre

Hi All!

I installed the i-sabre-k2m driver for my i-sabre es9038q2m card.
Its working fine. I use gmediarender, controlled from upnp app(mconnect,akcontrol on ipad), playing Tidal stream.
The volume control working, but on dietpi alsamixer, the “digital” volume always 100. This is the hardware volume. When use up/down keys in alsamixer then working, change the volume.
Maybe the apps use software volume control.

Just one question remained, how connect the app volume control(upnp
,mconnect,akcontrol) to alsamixer hardware volume control?

Thank you!


I found one solution here:


Squeezelite installed and added “-V Digital” to its config.
Now hardware volume control working fine from iPad/iPeng :slight_smile:

Thanks for providing the solution. Do with this option both volume controls work, via hardware and via iPad? In this case we might consider adding it by default, when installing via dietpi-software :thinking:.


I have no real hardware volume controller on i-sabre, just oled screen. There is volume indication on it and when i change the volume on ipad/ipeng or LMS or alsamixer, they all change the hardware volume (inside the es9038 dac chip) and oled indicate the changes.

(Audiophonics sell rotary digital encoder for this card separately and maybe this will work paralel with ipad/lms/alsa control.)