Slow transfer speed Dietpi <---> Shield TV (Bittorrent)


I have a Rpi4 2GB attached by cable in a 1Gb LAN to my router.

I also have a SHIELD TV PRO 2019 with a 5TB HDD attached (storage only).

When I transfer a file from my PC, laptop, or whatever to the Shield 5TB HDD, all is fine

But I have a qBittorrent server over Dietpi, downloading directly to the Shield 5TB HDD.

This 5TB HDD benchmarks around 40MB/s write and 0 (ZERO) MB/s write… a strange thing, because bittorrent downloads BUT VERY SLOWLY

File format in the 5TB HDD says “CIFS” and if I attach another USB 3.0 HDD 2TB f ex directly to the Pi, it benchmarks 40/40 aprox…slow too, but not so much as in the Shield…

What am I doing wrong? I also placed a SAMBA SERVER for the PC transferences and I see it is working fine… but the torrent problem persists… (I tried other servers like DELUGE, wth the same result…)

Any ideas?

did you tried to download to the local system directly and not to a network share? Does it behave same?

No, if I download to a “local” HDD plugged in mi pi, transfer is about 40/40 aprox…

and if you copy files from local HDD over to the Shield? How does it behave?

Fine, good speeds from my computer HDD/SDD to my Shield

I guess a misunderstanding. I meant to copy data from DietPi to the Shield.