SATA HAT Top board installation on DietPi


I’m trying to install the SATA HAT Top board on DietPi.
I’m using a Raspberry Pi 4 B.
I’m following the instructions on the Radxa Wiki ( )
When executing the provided command ( curl -sL | sudo -E bash - ), I get:
*** The script is not available on your system
*** Please visit to download and install manually.
So I manually downloaded the, ran ( sudo chmod +x ), then ( ./ ).
I get the same output as before.
I tried installing python first, same result.
Approximately a year ago, I successfully installed it on DietPi and under Respberry OS it also works.

I really want to use DietPi since it outperformes all other OS’s.
But I also want to use the top board. Otherwise it would be useless and I hate useless stuff.

Please help me!

I had a look into the script and it is expecting a OS called raspbian. Could you share following

cat /etc/os-release | grep ^ID= | sed -e 's/ID\=//g'

I guess it will return debian :wink:

Why? Because, since Bullseye our ARMv7 + ARMv8 images are based on Debian package repository. Pure Raspbian image would be the ARMv6 one

Anyway, the script is doing nothing else than downloading another script based on OS type. You could try it manually.

curl -sL | sudo -E bash -

Thank you!!

was this working?

I try this workaround that working for me:

  1. install manually apt install python3-rpi.gpio python3-setuptools python3-pip python3-pil python3-spidev pigpio python3-pigpio
  2. download script to /root/tmp
  3. make it executable (chmod +x /root/tmp/
  4. launch it ./
    SATA QUAD “Lords” could improve their scripts !!!