RPi Zero hangs on boot

Hi all,
flashed DietPi_v142_RPi-armv6-(Jessie).img to my sd, edited some things in dietpi.txt.
autoinstall, swap size, wifi, openssh instead of dropbear and thats basically it.

setup starts, updates, reboots etc. - everything looks good but the last bit doesn’t seem to work.
Stuck after cron and openssh started (successfully).

V144 RPi Zero (armv6l)

IP Address …

Default Login:
Username = root
Password = dietpi

blinking cursor



Thanks for the report, lemme see if I can replicate:

  • Wifi_Enabled=1
  • Wifi_KEY=xxxxxxxxxx
  • Swapfile_Size=0
  • AUTO_Install_Enable=1
  • AUTO_DietpiSoftware_SSHServerIndex=-2

Yep, looks like a bug with the new image, and, issues with firmware:

Images have been updated, should now be resolved:
Please re-download from DietPi - Lightweight justice for your SBC!, then write the new image. Let us know if any issues.

  • Wifi_Enabled=1
  • Wifi_KEY=xxxxxxxxxx
  • Swapfile_Size=256
  • AUTO_Install_Enable=1
  • AUTO_DietpiSoftware_SSHServerIndex=-2

keyboard and wifi code set to DE

still hangs at the exact same spot. thought it was my wifi adapter but it connected and updated just fine.

tried even less modifications with a usb to lan adapter. just swap to 256, keyboard to de, autoinstall 1
hangs at the very same spot. network works and did updates etc.


Can you try logging in at this point with keyboard attached, or, is the system hung completely? Does anything happen once logged in?

I believe this is simply the end of the automated installation and everything is ready for use.

okay, yeah that worked. when i press enter the prompt appears.
it still does but at least it connects to a lan before that so i can ssh.