RootFS is currently Read Only (R/O) mounted. Aborting...

When attempting to execute dietpi-config, I get the error

RootFS is currently Read Only (R/O) mounted. Aborting...

It says to run dietpi-drive_manager to re-enable. However, I’m unsure what to do after I enter the drive manager.

What is causing this error, it has happened to me multiple times and I just end up flashing a new image to reinstall. But this time is occured pretty much straight after installing. The only things I have done is:
[]Install OpenVPN
]Install qBittorent
[]Install ProFTP
]Set a static IP and change DNS servers

Thanks, I’m very new to all this so sorry if this is an obvious question.


many thanks for your report. What do you mean by “it has happened to me multiple times”?? How often this happen in the past? Usually this should not happen at all! Do you have a different SD card that can be used?


I am having the same problem just updated my Pi 4 Model B (armv71) to Dietpi v6.29.2 Latest version. I only have a 32GB micro-SD card in it. All storage goes to my NFS mounted NAS.

Installed Sonarr, Deluge, Nzbget changed to static IP and installed open vpn client.

Pi worked fine until Nzbget stopped downloading after about an hour. So I rebooted.

Now I get:

RootFS is currently Read Only (R/O) mounted. Aborting

DietPi requires RootFS to be Read/Write (R/W) mounted. Please run “dietpi-drive_manager” to re-enable.

When I try and run most of the diet-_____ commands. And none of my Softwares are running anymore

I retried the install 3 times and ran into the same error.

When I run dietpi-drive_manager it notices all my mounted drives but i get

cp: cannot create regular file ‘/etc/fstab’: Read-only file system

at the end.

in the dietpi-drive_manager it says
Please select a drive to see available options.

  • User data location: RootFS (/mnt/dietpi_userdata)

When I choose the /boot option and select Transfer RootFS
It says [WARNING] Partition must be unmounted, before format and RootFS transfer can begin.
Please unmount the partition, then try again.

I don’t know how to fix this, only started happening after the update any help would be appreciated.

I have exactly the same problem after upgrading to 6.29.2.

Any ideas?

I don’t know personally tried looking it up all night. Hopefully a moderator sees this thread. I also posted an issue on the github page

Hi Guys,

let’s use the discussion on GitHub to avoid to many open parallel streams.

It’s happened 3 times now. I’ve had to reinstall DietPi each time.

pls follow the GitHub post

I provided a possible workaround. But would be good if it can be verified. Issue seems to be using drive manager

Yes, same issue here too. I rebooted the Pi last night and noticed PiHole wasn’t working. Being a noobie, I tried to restore from backup thinking I had done something wrong but got this:

I am having the same issue. I have tried setting up from scratch and end up with the same failure. Dietpi is now completely unstable on a Raspberry Pi from what I can see. I started from scratch because I figured it was my original build that was causing the problem. It had been running for 1 1/2 years with out an issue till the upgrade.

I have tried 3 separate Raspberry Pi’s (3Bs) that I have laying around with 4 separate SD cards of different manufacturers and sizes (8gb/16gb/32, ScanDisk Ultra/Toshiba Exceria/Toshiba). Some last less than an hour before they get this fault, longest lasted less than 24hours.

I’m not installing anything crazy. Strickly using the dietpi-launcher to install Sonarr/Radarr/NZBGet and mounting a drive from another SBC that is running dietpi (luckily an ASUS TBS). Thats all.

It continually locks down with “rootFS is currently Read Only (R/O)”

Can’t access dietpi-config or anything. Tries 7 times not.

Guys, pls follow the GitHub post linked above.

Thanks Joulinar, workaround detailed in fixed the issue.


I’m new to dietpi. I have a problem that I don’t understand, that is blocking my entire pi.

I was managing my external drives with Dietpi’s Drive Manager, rebooted, and now I’ve got this :

Not a single software on my pi works now.
It tells me to run the drive manager, but I don’t know what to do next :

I searched on the forums about the issue, found someone who sent a fix :
Ok, but how do I get my PartUUID ? I don’t know how to apply the solution.
Here is my fstab file, I don’t know how to manage it but as I understood it manages drives and partition, I guess is could help.

Everything is now blocked. How can I fix this ? Any help is welcome. If you need more details about something, you can ask. I’m new and don’t know yet what would be needed to fix the issue. Have a good day

do you transferred your rootFS to an external device or is it still located on your SD card.

It is still on my SD card. I didn’t moved it.

I see you already in GitHub. pls continue there

To people seeing this later, go to the solution is there.

I second the link to

also backup your fstab before using the drive manager.

to backup cp /etc/fstab /etc/fstab.bak
to restore cp /etc/fstab.bak /etc/fstab

don’t forget to make rootFS writable before :wink:

mount -o remount,rw /

I know it is not much but i made a simple youtube video following the github guide