[Resolved] XU4 fails to power on

Issue is now resolved (image corruption), please download the latest XU4 DietPi image:

Hi There.

So I’ve tried again to Upgrade to V132 … same as V131 …

The Installation runs and u can reboot as often as u want. But if u take off complete - take away from power supply - it will never reboot again.

I’ve taken the DietPi_v127_OdroidXU4-armv7-(Jessie).img

last working IMG V130.

I’m sorry to bother u again.

My Image is on a 64GB NAND - only Storage in my Cloudshell.



Which kernel version?

uname -a

Can you replicate this issue on a fresh DietPi installation of the DietPi_v127_OdroidXU4-armv7-(Jessie).img, after its been updated?

Hi Fourdee,

What kernel version should the XU4 have with v132? I may have updated mine to 3.10.103+ (having several similar devices I can’t really remember).

I’ve had some rebooting problems recently in view of the above this may explain it.


Hi John,

Should be:

root@DietPi-XU4:~# uname -a
Linux DietPi-XU4 3.10.103+ #1 SMP PREEMPT Sat Sep 3 10:17:24 CEST 2016 armv7l GNU/Linux

I’ve had some rebooting problems recently in view of the above this may explain it.

Strange, not experienced any my end. Is there anything specific going wrong during the reboot?

Hi Fourdee,

It’s nothing consistent but once or twice I rebooted and nothing happened and once or twice I rebooted and it shut down and didn’t restart, so I had to power cycle. But mostly it’s working as it should.


Hi John,

Does sound PSU related. I believe during boot, the XU4 power usage peaks dramatically (eg: all usb devices are powered at once), CPU is probably running full clock. So any issues with “unstable power” would be most apparent then.

Although if i remember correctly, you upgraded the PSU on your XU4?

Hi Fourdee,

Yes I have a laptop style PSU 6A output so should be OK. It hasn’t happened for a few day so will likely remain unexplained :slight_smile:


I have the same problem : after poweroff not booting again. my kernel is 3.10.96+
tried two PSU’s one 6A and one 10A.

I think it has something todo with links to the initrd that are not correct
edit :
I just found out that the file
exynos5422-odroidxu3.dtb does not exist in the 132 boot partition

i’ve tried 4 times - every time same result

my kernel is 3.10.96+


copying exynos5422-odroidxu3.dtb as root from a fresh 127 image that has not been updated to 132 to my 132 emmc solved the boot problem for me, but I’m still at kernel 3.10.96+ and not at 3.10.103+ while the kernel 103 is available on the boot partition.

Hope this will help you

I noticed the problem way back at v122 (?) and stopped using Dietpi because of it. I have used my cloudshell with OMV, Ubuntu 16.04, and android with no power off problems. If the problem was with the power source you would think the issue would show up with other distros - but it seems to only be a problem with Dietpi. I am back to Dietpi because I love it, but it is not usable without a fix to the power down problem.

I have a cloushell with a 320G HD - the HD was used with the other distros also …

I tested the power off issue with a clean Dietpi - immediately after file system expansion and no other software installed and experienced the same problem. Hope this helps.


So just to clarify, the issues you and other users are experiencing are:
1. When you run the command poweroff, the XU4 will not power back on again? Either using the power on button, or, physically reinserting the PSU?
2. When you physically remove the PSU without shutting down, the XU4 fails to power on again?

Can all users who have experienced these issue please list:

  • The board revision number/dates on their XU3/4.
  • Power supply used (eg 5v/6a)
  • SD/EMMC card used and size.
  • If you have time, please try installing the following image http://oph.mdrjr.net/meveric/images/Jessie/Debian-Jessie-1.0~RC2-20151123-XU3.img.xz, (username = root, pw = odroid) run apt-get update and apt-get dist-upgrade -y && reboot, then please try to replicate the power on issue you are experiencing (eg: Pull power plug and put back in again, or poweroff)

Also created a Git ticket so we can investigate this: https://github.com/Fourdee/DietPi/issues/558

Hi There

As far as i know the last working Image was V130.

Can all users who have experienced these issue please list:

  • The board revision number/dates on their XU3/4.
  • Power supply used (eg 5v/6a)
  • SD/EMMC card used and size.

Power Supply (original one): 5v/4a
XU4 Rev 0.1 20151201
1st Try eMMC: 64GB
2nd Try MircoSD: 16GB
StartImage: DietPi_v127_OdroidXU4-armv7-(Jessie).img

huch - The Installation takes a while.
Tried on MicroSD 16GB
i’ve done this and the xu4 reboots. I only can read 6 Lines on the Display the rest seems to be black text-foreground … but the xu4 react on entered commands (reboot, poweroff).

Hi All,

I’ve recreated the XU4 image for DietPi: https://github.com/Fourdee/DietPi/issues/558#issuecomment-254057278

Could all users who are experiencing power on failures after shutdown, please download the image below and re-test. Thanks.

Image link: https://dietpi.com/downloads/images/DietPi_OdroidXU4-ARMv7-Buster.7z

In my case I used the desktop “shutdown” and did not remove the power plug. I also tried to remove the power plug after - but it did not boot.

Also, I used the “poweroff” and “shutdown” commands in terminal with the same results. At no time did I just pull the plug because that is really bad for the XU4 board and SD card.

PS - it appears the link in the post to try a new image is inactive …

I tried the RC2 link above after performing an update, upgrade, and reboot … “poweroff”, “shutdown now”, and restart via the push button worked as expected.


We moved the image to live download, new link is https://dietpi.com/downloads/images/DietPi_OdroidXU4-ARMv7-Buster.7z, apologies for that.

If you could run the same tests on the image above, i’d be extremely greatful. One of our other users has confirmed the issue is now resolved with that image, but, we’d like to get a few more results before closing this one.

Ok, but it will be a couple days … have to pay the bills!

No worries, know the feeling :wink:


Yes it runs with the new Image- tried on MicroSD 16GB.

Fourdee, is there a way now to upgrade my running System V130 to V134 without new Installation?