[Resolved] XU4 fails to power on

Possibly, but i’ll need to manually go through everything you have installed with you. DietPi installed software should be fine to copy over, but manual installs outside of DietPi-Software (eg: followed a guide and did some apt-get) wont be possible.

Can you run the following on the system and paste results:

dietpi-software list | grep '[[:space:]]=2'
df -h
ls -lha /mnt


only unrar i have installed without dietpi

root@DietPi:~# dietpi-software list | grep '[[:space:]]=2'
ID 0 | =2 | OpenSSH Client:  |
ID 3 | =2 | MC: midnight commander, powerful file manager |
ID 7 | =2 | FFmpeg: audio & visual libary |
ID 8 | =2 | Java: oracle java 8 jdk/jre libary |
ID 9 | =2 | Node.js: javascript runtime |
ID 16 | =2 | Build-Essentials: common packages for compile |
ID 17 | =2 | Git Client: git clone etc |
ID 42 | =2 | Plex Media Server: web interface media streaming server | | https://dietpi.com/forum/t/dietpi-software-details-for-all-installation-options/22/58
ID 44 | =2 | Transmission: bittorrent server with web interface (c) | | https://dietpi.com/forum/t/dietpi-software-details-for-all-installation-options/22/1
ID 62 | =2 | DietPi-Cloudshell: system stats displayed on lcd/panel | | https://dietpi.com/forum/t/dietpi-survey-information/32/1
ID 96 | =2 | Samba: feature-rich file server | | http://dietpi.com/phpbb/viewtopic.php?f=8&t=5&start=10#p56
ID 103 | =2 | DietPi-Ramlog: minimal, optimized logging | | https://dietpi.com/forum/t/dietpi-survey-information/32/1
ID 105 | =2 | OpenSSH Server:  | | http://dietpi.com/phpbb/viewtopic.php?f=8&t=5&start=10#p63
root@DietPi:~# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/mmcblk0p2   57G  4.2G   53G   8% /
udev             10M     0   10M   0% /dev
tmpfs           399M   24M  375M   6% /run
tmpfs           996M  4.0K  996M   1% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           996M     0  996M   0% /sys/fs/cgroup
tmpfs            10M  1.3M  8.8M  13% /DietPi
tmpfs           996M   36K  996M   1% /tmp
tmpfs            20M   28K   20M   1% /var/log
/dev/mmcblk0p1   71M   25M   47M  35% /boot
/dev/sdc1       5.5T  4.4T  834G  85% /mnt/usb_3
/dev/sdd1       5.5T  3.9T  1.3T  76% /mnt/usb_2
/dev/sdb1       5.5T  4.3T  892G  84% /mnt/usb_1
/dev/sde1       5.5T  3.0T  2.2T  58% /mnt/usb_4
root@DietPi:~# blkid
/dev/mmcblk0: PTUUID="000f1766" PTTYPE="dos"
/dev/mmcblk0p1: SEC_TYPE="msdos" LABEL="boot" UUID="96C3-9298" TYPE="vfat" PARTUUID="000f1766-01"
/dev/mmcblk0p2: UUID="e139ce78-9841-40fe-8823-96a304a09859" TYPE="ext4" PARTUUID="000f1766-02"
/dev/sdb1: UUID="86b8d807-340f-4873-8937-acd62adc4c2f" TYPE="ext4"
/dev/sdc1: UUID="cf58423f-08d8-425e-a554-cd2d5190c7af" TYPE="ext4" PARTLABEL="My Book" PARTUUID="e989f620-eeaa-443d-9f13-cffc57f5ad80"
/dev/sdd1: UUID="7b004310-3ce4-4ab1-9bd2-7889b4c4aa7b" TYPE="ext4"
/dev/sde1: UUID="3ae3ad10-05ec-4dd0-8608-68facd31268a" TYPE="ext4"
root@DietPi:~# ls -lha /mnt
total 20K
drwxr-xr-x  8 root root    1.0K Sep 22 18:51 .
drwxr-xr-x 21  502    1000 1.0K Jun 22 15:02 ..
lrwxrwxrwx  1 root root      10 Jul 22 15:20 dietpi_userdata -> /mnt/usb_1
drwxr-xr-x  2 root root    1.0K Jun 22 15:01 ftp_client
drwxr-xr-x  2 root root    1.0K Jun 22 15:01 samba
drwsrwsrwx 12  777 nogroup 4.0K Sep 30 21:28 usb_1
drwxrwxrwx  5  110 nogroup 4.0K Jun 26 13:42 usb_2
drwxrwxrwx  5  110 nogroup 4.0K Aug 22 22:15 usb_3
drwxrwxrwx  4  110 nogroup 4.0K Oct 17 17:39 usb_4


Ok, should be fine to do a DietPi-Backup and restore. This will essentially “clone” your system state.
But until we do this, we wont know if the power issue will reoccur on the new installation after we restore, if it does, indicates that files may have also been affected by the corrupt image, in which case, new install only.

  • On the system you have currently setup, run the following command:
dietpi-backup 1 /mnt/usb_1/dietpi-backup_export
  • Power off system.
  • Unplug all drives, except this one:
/dev/sdb1       5.5T  4.3T  892G  84% /mnt/usb_1
  • Grab a spare EMMC or SDcard (we dont want to overwrite this one yet) and write the new XU4 image on it.
  • Boot the system and go through the 1st run setup, say YES to external drive, then N (No) to formatting. Do not change any settings or select any software.
  • When the system is completed, run the following command:
dietpi-backup -1 /mnt/usb_1/dietpi-backup_export
  • Reboot system
  • Power off and test if the Power issue returns. If its non-existent, use DietPi-Drive_Manager to add the remaining drives.


This is something for the Weekend … i’ll try it on Fri or Sat,
Ty by now


OK - tried the new posted download -

Installed to the same, but reformatted, memory card to eliminate that variable.
Used software manager from Dietpi to install a desktop and tightVNC - then …

“Poweroff” and restarted with little button. Then “Poweroff”, pulled power plug, reinserted power plugt = all worked as expected!
Tried “Shutdown now” and restarted with the little button and did it again then pulled and reinserted the power plug = all worked as expected!

Appears the shutdown/power off/unplug power problem is solved …
Thanks for the effort.

Yep, confirmed by 3-4 users now. So all looks good: https://github.com/Fourdee/DietPi/issues/558

Thanks to everyone who helped report this issue and with testing!


so i’ve done this and it works now.
there were some troubles, but i hope i’ve done it the best way.

root@DietPi:~# dietpi-backup -1 /mnt/usb_1/dietpi-backup_export

Installing Rsync, please wait....

Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  openssh-client openssh-server
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 376 kB of archives.
After this operation, 615 kB of additional disk space will be used.
Get:1 http://ftp.debian.org/debian/ jessie/main rsync armhf 3.1.1-3 [376 kB]
Fetched 376 kB in 0s (679 kB/s)
Selecting previously unselected package rsync.
(Reading database ... 14622 files and directories currently installed.)
Preparing to unpack .../rsync_3.1.1-3_armhf.deb ...
Unpacking rsync (3.1.1-3) ...
Processing triggers for systemd (215-17+deb8u5) ...
Setting up rsync (3.1.1-3) ...
Processing triggers for systemd (215-17+deb8u5) ...

 Mode: Restore
 Please wait...

break!!! nothing happens - wait 30Min

2nd putty window and check mountstate
there i found out usb_1 is not usb_1 anymore!
so i modified /etc/fstab for mount usb_1 so i have it done before

UUID="86b8d807-340f-4873-8937-acd62adc4c2f" /mnt/usb_1 ext4 defaults,noatime,nofail 0 0

and take out all other mount records.


and now restore works

 [Ok] DietPi-Process Tool | Completed

 [Ok] Restore Completed.

root@DietPi:/mnt/usb_1# reboot
login as: root
root@'s password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Oct 22 08:11:34 2016
 DietPi     | Update available
 V130       | oDroid XU3/4 (armv7l)
 IP Address |

 Created by : Daniel Knight
 Web        : DietPi.com
 Twitter    : twitter.com/dietpi_

 Device image possible thanks to: Meveric
 DietPi's web hosting is powered by: MyVirtualServer.com

 DietPi relies on your donations for funding: http://goo.gl/pzISt9

 dietpi-launcher  = All the DietPi programs in one place.
 dietpi-config    = Feature rich configuration tool for your device.
 dietpi-software  = Select optimized software for installation.
 dietpi-update    = Run now to update DietPi (from V130 to V134).
 htop             = Resource monitor.
 cpu              = Shows CPU information and stats.


but … surprise surprise … its v130 again :smiley: lol

so i tried


and check poweroff issue. did not appear again.

tried to recreate my mountstate as i had before. but it’s not possible to remount
every drive i have with the same mountpoint with the drive manager.
so i modified again fstab as i had it before.

UUID="86b8d807-340f-4873-8937-acd62adc4c2f" /mnt/usb_1 ext4 defaults,noatime,nofail 0 0
UUID="7b004310-3ce4-4ab1-9bd2-7889b4c4aa7b" /mnt/usb_2 ext4 defaults,noatime,nofail 0 0
UUID="cf58423f-08d8-425e-a554-cd2d5190c7af" /mnt/usb_3 ext4 defaults,noatime,nofail 0 0
UUID="3ae3ad10-05ec-4dd0-8608-68facd31268a" /mnt/usb_4 ext4 defaults,noatime,nofail 0 0

but now is running without poweroff issue on v134

thanks for assistance @ all.


but now is running without poweroff issue on v134

Excellent, thanks for letting us know!

This confirms the image corruption was most likely caused by misaligned partitions and/or broken partition table, rather than corrupt filesystem. The USB3.0 SD reader I was using solely for Odroid image creation, packed in the other day, so most likely that is the culprit.

note to self: Don’t buy a Transcend USB 3.0 SD card reader.