(resolved) no sound


Wondering if someone can help me to get sound.

Have HDMI connection to monitor, volumecontrol set to 50% on the monitor, volumecontrol set to 80% and HDMI set with ALSA applet.

DietPi config has soundcard rpi-bcm2835 and lsmod shows that snd_bcm2835 is loaded.

I am not a Linux specialist and out of ideas where to look further.

Hope someone can point me in the right direction.

Tried the 3.5mm jack with earphones, but nothing there either.


Hi Seiko,

Please could you send me a bugreport, this will allow me to see your system settings.

Simply run the command below and follow the onscreen instructions. You’ll need to run this in a terminal (eg: console or LXterminal in the lxde menu):



Hello Fourdee,

Thx for quick response

bugreport sent, ref 78542e03f7fd-1


Everything seems to be in order, alsa is installed correctly. Can you try the following in a terminal and let me know the results:

1. Test audio with aplay:

wget http://www.wavsource.com/snds_2015-07-19_1628654123857389/movies/terminator/t1_be_back.wav
aplay -vv t1_be_back.wav

You should hear and see the audio being played. If not, let me know what happens.

2. Force HDMI audio output:

amixer cset numid=3
aplay -vv t1_be_back.wav

3. Try another HDMI cable/device:
Has the audio + HDMI always worked on this screen? Have you tried another HDMI cable or socket on the TV?

Hello Fourdee,

Thx again for your work/help.

still no sound.

This is the sreenoutput.

Playing WAVE ‘t1_be_back.wav’ : Unsigned 8 bit, Rate 11025 Hz, Mono
Hardware PCM card 0 ‘bcm2835 ALSA’ device 0 subdevice 0
Its setup is:
stream : PLAYBACK
format : U8
subformat : STD
channels : 1
rate : 11025
exact rate : 11025 (11025/1)
msbits : 8
buffer_size : 5513
period_size : 1376
period_time : 124807
tstamp_mode : NONE
period_step : 1
avail_min : 1376
period_event : 0
start_threshold : 5513
stop_threshold : 5513
silence_threshold: 0
silence_size : 0
boundary : 1445199872
appl_ptr : 0
hw_ptr : 0
############# + | 74%

Will verify with other device/cable first.


Problem found. It was the monitor.

Works fine now on other one.

Thanks again for the support.

Awesome, thanks for letting me know :slight_smile: