[Request] Recommendations on hardware setup (and restore options)

I’ve got some hardware issues (I think) and would like to make some changes.

I recently ran into problems with services not starting when booting my Pi 3B. I was periodically able to SSH into the Pi, but at other times it failed. Sometimes services would start, and sometimes they would not. I pulled the SD card and put it into another Pi, ran a fsck check and repair, and some issues were fixed. When I put the SD card back in the Pi 3B, everything (PiHole, VPN, NextCloud, PMS, SSH) worked again.

So a bit foolishly I decided I wanted to try out Syncthing. After running for half an evening Syncthing crashed and wouldn’t start back up. I did a journalctrl -n 100 to see that there were filesystem issues and Syncthing was unable to read/write to a certain location. Seemed to me my SD card was on its last leg.

I looked into options for simply not using it and came across USB booting. I’ve read quite a bit, but still have some questions and would appreciate any advice. Here’s the scoop on my current setup.

DietPi v6.28
Raspberry Pi 3b
32GB cheap SD card
128GB Samsung SSD (from an old Lenovo Yoga) connected via USB

  • this used to hold my dietpi-backup and user data folder
  • I transferred these to a 32GB USB Flash drive

  • the SSD has been wiped because I thought I wanted to use is as the RootFS but now I’m not so sure

The Questions:

  • Should I try running solely off USB?
  • If I do, should I get another USB drive for my backups, or would those work over a network connected drive?
  • Would reliability be better?
  • If I switch, should I really be starting from scratch or could I restore a backup from the 32GB flash drive?

  • Should I boot off the SD and run everything else off USB?

  • Should I get a better SD and keep my current setup with the external SSD for backups and user data?

Some More:

  • Before I cleared my SSD I transferred my user data to the 32GB Flash Drive, which worked fine
  • However because I was planning to switch to USB Booting off the SSD only, I tried to transfer my user data back to the SD card so I could clone a complete system to my SSD.
  • Transferring the user data failed because there was not enough space on the card, however the SD card is still being shown as the location for my user data
  • The USB Flash no longer shows as my user data location, although it still does contain all of my user data.
  • Can I switch the location of user data back to the USB, or will it overwrite the folder on the USB with the incomplete user data folder on the SD card?
  • Currently I can’t run several apps because user data connections cannot be made
  • Before the hardware issues on the SD card, I had a great setup and the apps were running very well. I’d really like to not have to start that all over again, and I do have some valid data (though no real backups probably) that I’d love to retain. But I don’t want to buy a newer and better SD card to replace the dying one, just to get me another year down the road. Especially if a different setup can be put in place for better longevity.
    I realize that’s a lot of backstory and whatnot, so please share any thoughts or ask any questions and I’ll happily answer what I can.


If you like to migrate your RootFS (incl user data) to an USB/SSD device, you might look into this:


@Joulinar Thanks. that is also my thread where I was having issues with services failing to start. I’ve did migrate my RootFS and Userdata to an external USB SSD and thought I was all set, but then it crashed again and became unavailable and I had to restore a backup (again). Something on the system is unstable and I’m not sure what it might be. After trying the following setups (OS on SD, Userdata on USB / Boot on SD, OS and Userdata on USB / and everything on USB) and none of them working for long, I figured I should start from scratch. I’m trying now to get to a USB only setup. If that fails I’ll try SD boot with USB OS and Userdata. Thank you again for all your help in the various threads I’ve created for various reasons (which all seem to circle back to some issue with my OS, or storage media as a likely culprit for my troubles).

ah sorry, I did not checked that it was you as well. :open_mouth:

No problem. I believe a majority of my issues with a USB only system were from power supply being too low. After bumping up my powers supply things seem more stable.

crossing fingers it will stay that way.