RaspberryPi4 RPi4 Upgrading from existing SD card setup to boot from SSD


I did the steps provided in the first post. Made an img-file from the sd-card, flashed that to the SSD drive. Then followed the instructions from https://www.instructables.com/Booting-Raspberry-Pi-3-B-With-a-USB-Drive/

In short:

sudo apt update && sudo apt upgrade && sudo reboot
echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt
sudo reboot

vcgencmd otp_dump | grep 17:


The OTP seems to have been programmed correctly


When restarting the PI nothing happend :frowning:

I’m afraid that something didn’t quite work in the original instructions on the first post

Do you have a pen steck? Would it be possible to flash a fresh copy of DietPi on that stick and try to boot from it? Just to check of USB boot is working.

It’s not a stick, it’s a ‘normal’ SSD drive.

Will try to flash a new Dietpi install tomorrow.

I guess we misunderstood. For testing, you could try using a pen stick instead of your SSD to see how it behave.

Tried with USB stick I had lying around. Didn’t want to startup either. So I flashed some other SD-card with the img I created earlier in the hope that will work again., but that also fails now.

Btw. I can see that the PI is up (at least in the DHCP table of my router it shows up.

does it boot with the original SD card? How does it behave if you flash a complete new/fresh image to SD/ pen stick?

Just flashed the newest Bullseye to a stick, and it seems that one is booting. At least I could login and start the dietpi install. So, waiting to see what happens next.

Seems to be working so far.

ok means USB boot is working well. Probably there is an issue with the *.img file you create because it was not working as well on another SD card if I understood correctly? How did you created the image?

I cloned the card with Win32 diskimager.

Usually this should be fine. Strange that it was not working on another SD card as well.

Even found another problem.

Armv8 (64bit) doesn’t work, but the 32bit version does. Problem is that a WordPress backup (Backupguard) needs 64 bits to restorre the bakups…

usually there shouldn’t be any difference. How long did you wait on the 64bit version to boot?

Wow - this went really smooth and worked perfectly! Thanks so much for posting!

I haven’t resized yet (step 5) - will do that tomorrow :slight_smile:

in meantime we created a small blog post for this kind of activity https://dietpi.com/blog/?p=1236

bookmarked for the future - thanks!!

the blog is describing as well how to move from a lager SD card to a way smaller device :slight_smile:
Just in case some has started with a too large device first.

yep - I think you just described me :rofl:


Will existing files be preserved on the external boot drive if I follow the guide on the blog?


usually not.