qBitTorrent gets stuck after some time until service manually restarted

Greetings,

I am experiencing a problem with qBitTorrent software.

Did a clean install, it works but after some time working, it would just stuck - web interface works, I can add/remove torrents but it won’t download anything.

For example, if I add a new torrent, it would sit there with “downloading metadata” (if magnet was used) or “stalled” (if torrent file was used) for eternity.

But, if I SSH to the my Pi 4 that hosts it and do “service qbittorrent restart” - it will start working again… sometimes even for days, until it gets stucked again.

It kind a grinds my gears.

Any known solution to this? Thanks in advance!

Does it stuck also on popular torrents?

Try to upgrade to newer version https://dietpi.com/forum/t/how-to-install-qbittorrent-4-3-9-vesrion/6092/1

Accordding to Github a lot of people have this issue and they found various solutions for this.

So the top solutions I found in the short time are:
[] wrong network interface was set, change it in qBittorent settings, under Advanced
[
] the used VPN software created another network interface, see line above for fix
[] set to randomize port at startup fixed it
[
] change upload rate from 0 to something else fixed it
[*] change back to older version fixed it

It’s a mystery, or just a lot of bugs which cause this behaviour :rofl:

Have a look: https://github.com/linuxserver/docker-qbittorrent/issues/45 (I know it#s for docker-qbittorent, but there are the most suggested solutions)
and: https://github.com/qbittorrent/qBittorrent/issues/14276
And many many more if you search for your own.

Does qbittorent indicates something like this:

?