Plex Server web interface not working

Hi everyone.

First I want to thank all of the people who made DietPi possible. It is an amazing solution : all is simple, integrated, easy to understand and everything works as dreamed ! Amazing ! So much amazing I already decided to make a donation. It’s the 2nd time in my life I am making a donation for a free software (shame on me not to have made that more often !) so it proves at which point I am greatly positively surprised and loving DietPi :slight_smile:

I’m trying to install Plex server on a RaspBerry Pi 3. Install itself is easy and I had no problem with it. Only thing to be careful is to select “en_US.UTF8” as default locale at the end of the install process. Did all of that and it ends saying everything is done. But when I go to http://192.168…:32400/web my browser says it can’t reach the destination. And that’s my problem here because it means I can’t do the initial first launch setup of the Plex Server.

I know the Pi is working correctly because I can reach http://192.168 and also http://192.168…/nextcloud works perfectly. I confirmed “plexmediaserver” is running on the Pi.

I tried to use a different browser, I tried to clear the history/cache of my browser, tried to purge the plexmediaserver (following same type of issue found on this forum), even tried to uninstall “plexmediaserver” and then install it but the same situation persists.

Installed on the DietPi I have dropbear, proftp, lighttpd (mysql), nextcloud, NoIP, PiHole and Plex obviously. So nothing too “weird” and for now I did nothing “unusual”. I just followed instructions for installations of each ones and everything works excepting the little details I keep for later resolution (my isp blocks port 80 so I have to found a way to connect to Nextcloud from outside, I have to understand how to have an ssl certificate with NoIP).

If someone would have an idea how to fix the situation with Plex I would greatly appreciate :slight_smile:
If you need more infos from my setup (install logs, etc…) I most probably would need some instructions how to find them as I don’t have the pretension to master the command line nor the linux system (yet).

Thanks !

Hi Sinok,

Thanks for your kind words and using DietPi, really appreciate it :slight_smile:

Did a test install of PMS, working fine here, very strange.

First, lets try a reinstall of PMS, please run the following commands:

dietpi-software uninstall 42
dietpi-software install 42

Once completed, reboot your system, then check to see if the PMS website is available (eg:

Failing that, please send us a bug report as this will contain system information we can use to try and debug.
To send a bug report, please see:

Thanks for your help. So I did the commands provided. at the end of the installation it doesn’t ask me the “usual” setup such as the question regarding locale etc… I reboot. Went to IP/web but here I have a nice “404 - page not found”.

I sent the bug report :slight_smile: (it may be a simple thing I missed somewhere I hope).

EDIT : just realized for this try I was typing the address without the port “32400” (sorry lack of sleep). Added the port but it still can’t connect as original problem (no page 404 anymore, just Safari saying “can’t connect to the server…”).

Just for information :

I changed my setup a little bit : After some search I’ve seen Pi-Hole could sometimes interfere with the port 80 and in addition having Pi-Hole on same Pi used for everything else may, at some point, slow down internet traffic. So now I have a 2nd Raspberry Pi which is dedicated to Pi-Hole only. I setted it up as new with Pi-Hole, works great that’s nice :slight_smile:

Concerning the first RaspBerry Pi with Plex I restarted everything from scratch : erased the sd card, formatted the 1To external usb hdd connected to it, re created a new sd card and re-installed it as new with Nextcloud (because it will be its main purpose), Fail2Ban, Plex, NoIP. Install went perfect, no surprise (seriously DietPi team you did a so great job that there is no way to mess up install ! congrats !), I let the system installed what it needed. Now at the end the install is done. Go to http://theipofthepirunningplex:32400/web and I still have this “Can’t connect to the server” page :cry:

Very bizarre.

I noticed you are having similar issues with NextCloud. My only suggestion is to allow for a remote desktop session, where I can attempt to debug/fix both issues. This would require a VNC server on a Windows PC with Kitty installed. Let me know if you are interested in doing this?

If you are, let me know if you will need assistance setting up VNC and port forwarding on your router (TCP 5900), then i’ll walk you through it.

My Nextcloud problem is more with the iOS app “only”. But… yes at the end it’s a question of something not connecting to my DietPi installation in both scenarios so… I assume they could have similar cause.

I have an old pc I had never used since a long time I could try to look into it to install a VNC server. But I have no clue what you mean by “Kitty installed” ? What is Kitty ?


KiTTY is a SSH Terminal Client for Windows. Something like “PuTTY”, but with more and nice features.

Have a look:

No installation is needed, if you use portable version “kitty_portable.exe”.

Last version can be found on his google drive

But you can as well use Mac OSX with VNC server and vssh lite installed.

Hi Sinok,

My Nextcloud problem is more with the iOS app “only”

Either way, i’ll take a look at the core webserver and see if there is anything we can do.

I have an old pc I had never used since a long time I could try to look into it to install a VNC server.

Excellent. Do you have Skype?
Should help with getting this arranged and setup. Please email with your skype ID and i’ll get it booked in with you asap.

Thanks a lot for your help… I finally had time to follow your advice in formatting my sd card, reinstalling DietPi from scratch with just Plex : it works perfectly :slight_smile:

Now I am going to install what I need one by one and see if Plex would stop working what would be the last thing installed. As we can say the issue I had is not caused by Plex then I put this topic in “solved”.


I noticed once Plex is installed and working… then Nextcloud is not working at all (can’t reach page on http://192.168…/nextcloud). Then if format my sd card start from scratch again and if I install both in the same time and then setup Nextcloud first… it works… but Plex not working anymore (can’t access the http://…:32400/web which was my original problem). It’s weird. It’s like if Nextcloud and Plex can’t be running both in the same time on the same Raspberry Pi :question:

I’m having a similar issue and get the same error that I can’t see the server.
I have another place media server running on my network. Can there be an option in the setup script where you can setup the plex port number ahead of time?
I think this may be the issue with my setup.

I had this working a few dietpi versions ago along with multiple other running services and believed I tried the idea of only setting up the plex service first but still got the same error.

Tonight I’m getting a new 64GB Microsoft card and will try again with a clean install on that.

Great work again getting this setup.

I had the same issue.

I think it’s because lighttpd isn’t listening to port 32400

Try this code and see if port 32400 is being listened to.

netstat -tulpn

Also can someone please post how to listen to this port via lighttpd and nginx? (and let me know if its the same code?) tnx

Cheers ~ hope that helps.


Plex doesn’t use/require a webserver. Its embedded in the program.

Ok, does it conflict with lighttpd or is nginx better to use in conjunction?

Thanks in advance (again) :smiley:.

PMS + Lighttpd/Nginx/apache should be fine. PMS uses port 32400.

Thanks for the reply. I noticed that when I was updating, your install script with shut down the installed services, and start them back at the end. I see PMS shutdown and start back up, but the connection is refused. My guess is its a raspberry pi model B doesn’t have the RAM to hold it?
I’ll see if I can find one of my pi II laying around.
Thanks again for your help.


Unfortunately, PMS wont run on ARMv6, due to lack of binaries available, and, no source code that we can use to compile either. Its disabled for ARMv6 boards inside the main dietpi-software menu interface:

Did you use command line to install this, eg?

dietpi-software install 42

RPi 2/3 will be fine (ARMv7 is supported).

I’ve found my self facing the same issue today;
Yesterday I’ve installed DietPi on my Odroid C2. Installation went smooth and the installation of Plex Server worked.
I then tried to mount NFS shares; this didn’t work - I think it’s my Synology NAS acting up.
Then I tried Samba/CIFS. That did work. I’ve created 2 mounted directories by editing fstabs. The mounts were there.
Next step was to setup PlexServer. It started indexing, but my client couldn’t connect to the C2;
I’ve tried again today, but now it starts falling apart :-/

Today I couldn’t reach the web interface anymore. I turned back the mapping changes I’ve made but that didn’t work.
I’ve found this command:

systemctl status plexmediaserver

That reported:

   Loaded: loaded (/etc/init.d/plexmediaserver)
   Active: active (exited) since Mon 2017-05-01 15:23:06 BST; 3h 38min ago
  Process: 919 ExecStart=/etc/init.d/plexmediaserver start (code=exited, status=0/SUCCESS)

I did some digging and I belief this means the whole process isn’t started.
So something is wrong;
I flashed the SDCard again and reinstalled the Plexserver multiple times, but it didn’t solve anything.

I’ve tried this command I’ve found somewhere:

ln -s /lib/arm-linux-gnueabihf/ /lib/

But that didn’t do anything either.

I really could use some help; thanks

I’ve tried again today with a fresh image.
I noticed that Plex was now working, but after installing Samba it broke again. Last time I first installed Samba.
So I think the combination is somehow broken.
I’ve found instructions on how to install a samba client here.
On a fresh image I FIRST installed Plex Server and then this command to install the client:

apt-get install samba samba-common-bin

I manually edited /etc/fstab to reinsert my shares and everything is now working great!


How did you install Samba Server or Client, did you use dietpi-software / dietpi-config ?